summaryrefslogtreecommitdiff
path: root/media-libs/libopenglrecorder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-libs/libopenglrecorder
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-libs/libopenglrecorder')
-rw-r--r--media-libs/libopenglrecorder/Manifest2
-rw-r--r--media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild30
2 files changed, 15 insertions, 17 deletions
diff --git a/media-libs/libopenglrecorder/Manifest b/media-libs/libopenglrecorder/Manifest
index fdae81e5e1be..94e223dc3b43 100644
--- a/media-libs/libopenglrecorder/Manifest
+++ b/media-libs/libopenglrecorder/Manifest
@@ -1,3 +1,3 @@
DIST libopenglrecorder-0.1.0.tar.gz 101788 BLAKE2B 9fbd9e5acb51c033f533166cf4f55863d97331ca0d506ada7f0e2ffaf790a20b74521668d80dfe4ef230a6bf44466b5f5eda9ab6d4a248db730b0596ce441f6f SHA512 2264b5999870d89ab10366bbbbccfce8ef7c2674bb054005f4e182af2cb10c7553f97402feadc528da94608a47db030a07987b11470044965d70cd69fe47bacd
-EBUILD libopenglrecorder-0.1.0.ebuild 1018 BLAKE2B 6105b7bb44850f6a960727687e09372afd079a1c59cd9d956736bb5abd2e90d9bff0c67e698e1ca791db6ce0276c9c643258a2a26ffce24960218448c3092d97 SHA512 9e2fed49f6b5a21c3c238e2ea9a440562c6ffe6ba54c1e338605792c4588410daa9e61f6f7fcfecf6d892e41b94dc36f89dc1b30be2a9508825627dba58625a9
+EBUILD libopenglrecorder-0.1.0.ebuild 994 BLAKE2B 56b7f03d2d6394559dcd9e8e5f4326cc99852a9ee5c555901f3e846febbedfd3743fb709309816c54c629695f7f4bf1cdfa4fd0bec0c8029c8bc97ad5ba5e07e SHA512 4d5b88c42be3b0b7045010162da4e93eb1472dc035422a4c93897880fdec9f3cee2a5a654779bcaf5fb5b4de0bfce5ea7023303cde86d5a20d7ee5f1297db7ef
MISC metadata.xml 533 BLAKE2B cd75ce8bc96e05b6c7284aa8d56f04b7decda54a9e14c18d553ec26ac4913319b0efe3756d6c8c23e8b3afb12081ba291db692e521d9ee7de52b1cdcbb165259 SHA512 d4067a58da4f73a5399a72713c2467f19936a1480b502798e6b02896f7930701d065f89de57b74e1fa6b92ef793db3aa1c7e059437fb1ff0167cefcdab744b1f
diff --git a/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
index 317958e4f21a..f948ce3df0ba 100644
--- a/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
+++ b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-multilib
@@ -14,7 +14,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openh264 sound vpx"
-RDEPEND="media-libs/libjpeg-turbo[${MULTILIB_USEDEP}]
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ media-libs/libjpeg-turbo[${MULTILIB_USEDEP}]
openh264? ( media-libs/openh264[${MULTILIB_USEDEP}] )
sound? (
media-libs/libvorbis[${MULTILIB_USEDEP}]
@@ -22,23 +26,17 @@ RDEPEND="media-libs/libjpeg-turbo[${MULTILIB_USEDEP}]
)
vpx? ( media-libs/libvpx:0=[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${DEPEND}"
-DOCS=(
- CHANGELOG.md
- README.md
- USAGE.md
-)
+DOCS=( CHANGELOG.md README.md USAGE.md )
multilib_src_configure() {
local mycmakeargs=(
- -DBUILD_PULSE_WO_DL=ON
- -DBUILD_SHARED_LIBS=ON
- -DSTATIC_RUNTIME_LIBS=OFF
- -DBUILD_WITH_H264=$(usex openh264)
- -DBUILD_RECORDER_WITH_SOUND=$(usex sound)
- -DBUILD_WITH_VPX=$(usex vpx)
+ -DBUILD_PULSE_WO_DL=ON
+ -DSTATIC_RUNTIME_LIBS=OFF
+ -DBUILD_WITH_H264=$(usex openh264)
+ -DBUILD_RECORDER_WITH_SOUND=$(usex sound)
+ -DBUILD_WITH_VPX=$(usex vpx)
)
cmake-utils_src_configure
}