summaryrefslogtreecommitdiff
path: root/media-libs/libopenaptx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /media-libs/libopenaptx
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'media-libs/libopenaptx')
-rw-r--r--media-libs/libopenaptx/Manifest4
-rw-r--r--media-libs/libopenaptx/libopenaptx-0.2.0.ebuild49
-rw-r--r--media-libs/libopenaptx/libopenaptx-9999.ebuild49
-rw-r--r--media-libs/libopenaptx/metadata.xml16
4 files changed, 118 insertions, 0 deletions
diff --git a/media-libs/libopenaptx/Manifest b/media-libs/libopenaptx/Manifest
new file mode 100644
index 000000000000..a1e15e075b09
--- /dev/null
+++ b/media-libs/libopenaptx/Manifest
@@ -0,0 +1,4 @@
+DIST libopenaptx-0.2.0.tar.gz 27797 BLAKE2B b178a9aaf78796c9219d9e7066ff985ce9f5dd86a6926ae22e373f2822090ad313efe04d5cf607940f1042bd27ddf5484d7e8298dfff91a8ae5596cec7ad5fa9 SHA512 d57e5084b398eec2ad49c9893baa496651c139abfb95692c834a4691bc4bb951d0b1afdd499a8b67c84b873407b584965d3a045d8ef3d9e62b3ccf45de22809a
+EBUILD libopenaptx-0.2.0.ebuild 1022 BLAKE2B ed3d85400142cf3d3fd9de1bf37e2cda897a952f07d2168252c575b0701d5a9003846f4b5605690512bf42f76c69b1f25c9e3a8ca2f0e52943dead7930504179 SHA512 4e9477a48a0cf0d4daea89bef6819b23eefbd8e619cf0973554e56306a450090a3ee7d723d23cb6be7b02c901136cff38c6be8f72844a01c76104b86f34992e9
+EBUILD libopenaptx-9999.ebuild 1022 BLAKE2B ed3d85400142cf3d3fd9de1bf37e2cda897a952f07d2168252c575b0701d5a9003846f4b5605690512bf42f76c69b1f25c9e3a8ca2f0e52943dead7930504179 SHA512 4e9477a48a0cf0d4daea89bef6819b23eefbd8e619cf0973554e56306a450090a3ee7d723d23cb6be7b02c901136cff38c6be8f72844a01c76104b86f34992e9
+MISC metadata.xml 475 BLAKE2B ce3ccc5f113c6178230b372c55e9992731ff55477bdde2efcca199b73d7b2ec66419dcba89c3f368ff9b7ef54011bd92c6cecaf9b3cd64b5a6ab8ea2e0b0d1ec SHA512 7bde88afdf7a137ea5ec1b491dda467eec36d2897f0bd009ca22066614db64531fe5b343cdb426b1e80ef6cf8011db1c43a0a525b9b302496e04cd7d2e97dbc0
diff --git a/media-libs/libopenaptx/libopenaptx-0.2.0.ebuild b/media-libs/libopenaptx/libopenaptx-0.2.0.ebuild
new file mode 100644
index 000000000000..bac055db1328
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="cpu_flags_x86_avx2"
+
+src_compile() {
+ tc-export CC AR
+
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR=$(get_libdir) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ all
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ DESTDIR="${D}" \
+ LIBDIR="$(get_libdir)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ install
+
+ rm -f "${ED}/usr/$(get_libdir)"/libopenaptx.a || die "Failed to remove static lib"
+}
diff --git a/media-libs/libopenaptx/libopenaptx-9999.ebuild b/media-libs/libopenaptx/libopenaptx-9999.ebuild
new file mode 100644
index 000000000000..bac055db1328
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="cpu_flags_x86_avx2"
+
+src_compile() {
+ tc-export CC AR
+
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR=$(get_libdir) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ all
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ DESTDIR="${D}" \
+ LIBDIR="$(get_libdir)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ install
+
+ rm -f "${ED}/usr/$(get_libdir)"/libopenaptx.a || die "Failed to remove static lib"
+}
diff --git a/media-libs/libopenaptx/metadata.xml b/media-libs/libopenaptx/metadata.xml
new file mode 100644
index 000000000000..5e724bf54f34
--- /dev/null
+++ b/media-libs/libopenaptx/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>joakim.tjernlund@infinera.com</email>
+ <name>Joakim Tjernlund</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>codec@gentoo.org</email>
+ <name>Gentoo Codec Project</name>
+ </maintainer>
+</pkgmetadata>