summaryrefslogtreecommitdiff
path: root/media-libs/libmypaint/libmypaint-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /media-libs/libmypaint/libmypaint-1.6.1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'media-libs/libmypaint/libmypaint-1.6.1.ebuild')
-rw-r--r--media-libs/libmypaint/libmypaint-1.6.1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/media-libs/libmypaint/libmypaint-1.6.1.ebuild b/media-libs/libmypaint/libmypaint-1.6.1.ebuild
deleted file mode 100644
index 2842166e79e2..000000000000
--- a/media-libs/libmypaint/libmypaint-1.6.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit python-any-r1 toolchain-funcs
-
-MY_PV=${PV/_beta/-beta.}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Library for making brushstrokes"
-HOMEPAGE="https://github.com/mypaint/libmypaint"
-SRC_URI="https://github.com/mypaint/libmypaint/releases/download/v${MY_PV}/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="ISC"
-# See https://github.com/mypaint/libmypaint/releases/tag/v1.6.1
-# https://github.com/mypaint/libmypaint/compare/v1.6.0...v1.6.1
-SLOT="0/0.0.0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv x86"
-IUSE="gegl introspection nls openmp"
-
-BDEPEND="
- ${PYTHON_DEPS}
- nls? ( dev-util/intltool )
-"
-DEPEND="
- dev-libs/glib:2
- dev-libs/json-c:=
- gegl? (
- media-libs/babl
- >=media-libs/gegl-0.4.14:0.4[introspection?]
- )
- introspection? ( >=dev-libs/gobject-introspection-1.32 )
- openmp? ( >sys-devel/gcc-5:*[openmp] )
- nls? ( sys-devel/gettext )
-"
-RDEPEND="
- ${DEPEND}
- !<media-gfx/mypaint-1.2.1
-"
-
-src_configure() {
- tc-ld-disable-gold # bug 589266
-
- econf \
- --disable-debug \
- --disable-docs \
- $(use_enable gegl) \
- --disable-gperftools \
- $(use_enable nls i18n) \
- $(use_enable introspection) \
- $(use_enable openmp) \
- --disable-profiling
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -type f -delete || die
-}