summaryrefslogtreecommitdiff
path: root/media-libs/libmypaint/libmypaint-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-libs/libmypaint/libmypaint-1.6.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-libs/libmypaint/libmypaint-1.6.1.ebuild')
-rw-r--r--media-libs/libmypaint/libmypaint-1.6.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libmypaint/libmypaint-1.6.1.ebuild b/media-libs/libmypaint/libmypaint-1.6.1.ebuild
new file mode 100644
index 000000000000..f091e98a2772
--- /dev/null
+++ b/media-libs/libmypaint/libmypaint-1.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit autotools python-any-r1 toolchain-funcs xdg-utils
+
+MY_PV=${PV/_beta/-beta.}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Library for making brushstrokes"
+HOMEPAGE="https://github.com/mypaint/libmypaint"
+SRC_URI="https://github.com/mypaint/libmypaint/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ISC"
+# See https://github.com/mypaint/libmypaint/releases/tag/v1.6.1
+# https://github.com/mypaint/libmypaint/compare/v1.6.0...v1.6.1
+SLOT="0/0.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="gegl introspection nls openmp"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ nls? ( dev-util/intltool )
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-c:=
+ gegl? (
+ media-libs/babl
+ >=media-libs/gegl-0.4.14:0.4[introspection?]
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )
+ openmp? ( >sys-devel/gcc-5:*[openmp] )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
+ !<media-gfx/mypaint-1.2.1
+"
+
+src_configure() {
+ tc-ld-disable-gold # bug 589266
+ econf \
+ --disable-debug \
+ --disable-docs \
+ $(use_enable gegl) \
+ --disable-gperftools \
+ $(use_enable nls i18n) \
+ $(use_enable introspection) \
+ $(use_enable openmp) \
+ --disable-profiling
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}