summaryrefslogtreecommitdiff
path: root/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/liblingoteach/liblingoteach-0.2.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/liblingoteach/liblingoteach-0.2.3.ebuild')
-rw-r--r--media-libs/liblingoteach/liblingoteach-0.2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild b/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild
new file mode 100644
index 000000000000..054e996b92ca
--- /dev/null
+++ b/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+DESCRIPTION="A library to support lingoteach-ui and for generic lesson development"
+HOMEPAGE="http://lingoteach.sourceforge.net"
+SRC_URI="mirror://sourceforge/lingoteach/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="debug zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --disable-dependency-tracking \
+ $(use_enable zlib compression) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake HTML_DIR="/usr/share/doc/${PF}" DOC_MODULE="" \
+ DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+}