summaryrefslogtreecommitdiff
path: root/media-libs/libirman/libirman-0.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-libs/libirman/libirman-0.4.5.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-libs/libirman/libirman-0.4.5.ebuild')
-rw-r--r--media-libs/libirman/libirman-0.4.5.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/media-libs/libirman/libirman-0.4.5.ebuild b/media-libs/libirman/libirman-0.4.5.ebuild
index 5dddb2d83849..f8f4a774babb 100644
--- a/media-libs/libirman/libirman-0.4.5.ebuild
+++ b/media-libs/libirman/libirman-0.4.5.ebuild
@@ -1,30 +1,35 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils eutils toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="library for Irman control of Unix software"
HOMEPAGE="http://www.lirc.org/software/snapshots/"
SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2 LGPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="static-libs"
-
-DOCS=( TECHNICAL NEWS README TODO )
src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
tc-export CC LD AR RANLIB
- autotools-utils_src_prepare
+ econf --disable-static
}
src_install() {
- autotools-utils_src_install LIRC_DRIVER_DEVICE="${D}/dev/lirc"
+ export LIRC_DRIVER_DEVICE="${ED}/dev/lirc"
+ default
+ dodoc TECHNICAL
+
+ dobin test_{func,io,name}
- dobin ${AUTOTOOLS_BUILD_DIR}/test_{func,io,name}
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}