summaryrefslogtreecommitdiff
path: root/media-libs/libirman/libirman-0.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libirman/libirman-0.4.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libirman/libirman-0.4.5.ebuild')
-rw-r--r--media-libs/libirman/libirman-0.4.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libirman/libirman-0.4.5.ebuild b/media-libs/libirman/libirman-0.4.5.ebuild
new file mode 100644
index 000000000000..5dddb2d83849
--- /dev/null
+++ b/media-libs/libirman/libirman-0.4.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="library for Irman control of Unix software"
+HOMEPAGE="http://www.lirc.org/software/snapshots/"
+SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="static-libs"
+
+DOCS=( TECHNICAL NEWS README TODO )
+
+src_prepare() {
+ tc-export CC LD AR RANLIB
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install LIRC_DRIVER_DEVICE="${D}/dev/lirc"
+
+ dobin ${AUTOTOOLS_BUILD_DIR}/test_{func,io,name}
+}