summaryrefslogtreecommitdiff
path: root/media-libs/libiptcdata
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libiptcdata
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libiptcdata')
-rw-r--r--media-libs/libiptcdata/Manifest5
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild50
-rw-r--r--media-libs/libiptcdata/metadata.xml22
3 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/libiptcdata/Manifest b/media-libs/libiptcdata/Manifest
new file mode 100644
index 000000000000..a1d1f567c06c
--- /dev/null
+++ b/media-libs/libiptcdata/Manifest
@@ -0,0 +1,5 @@
+DIST libiptcdata-1.0.4.tar.gz 569132 SHA256 79f63b8ce71ee45cefd34efbb66e39a22101443f4060809b8fc29c5eebdcee0e SHA512 8656b2febaec133d1a8783252047672bebd58ae9ceab5477c4acfa35bcc381dfda08b655a957b962878af28c69deff77d920e780c84b4debdff2f980b3de94e8 WHIRLPOOL c97e9c5566840e5e0ecede481650b91108b047d0324b9260d5083d46e55f0bfe71bf6d91d504fcc59f374dd77a0818397fed87ca8b73ecf0bfe769d43fa2348a
+EBUILD libiptcdata-1.0.4-r1.ebuild 1244 SHA256 2c0af542ea607047ea7b73626e2a62373a1a7c7297634e628284c2406b854f60 SHA512 9c89c917306faa0de7ee545bae71c8d1e54a744b6d1bb5d92dbcee51df5f5943adb38f6d6d0ec5c5342320ad21c65b7f6540c58f50976578168332508f3031f7 WHIRLPOOL f5e5f042463c9e29da2482ef0b96ec0afddf7e26f0782aed98c96149245420f20166564203bb3a14b259c6025dec8ce02322e984795b5903639a4395c9d18088
+MISC ChangeLog 2392 SHA256 29ad3fd40a6627804c6791b9f59a20ac55c485c645c972317a281655935115a5 SHA512 8ce35271ebdbdbf29aa054d2857140f48a29f9e3a67a2efa9fc9d9a301ad1b78a075d474445a59f2d9121c4691e94222150ef727d34948189700d92014f32aa9 WHIRLPOOL 4825de4d237f340d39c5be4e184be4f94384867b34fa71193dcdfcdc63418cd930a5dbbad683c53d6669606894ae3da84fa4464d83eaa0d663c01104ab7b95f9
+MISC ChangeLog-2015 3639 SHA256 8239b68c6b1c20ffc1be5cb5ef489ee85c370468f6f974415233c2d002e27e13 SHA512 c3806de9630b54af3f10dfb7cae985a7a0b1022f50a2aaa0b2bf21def50e6fe98d79d95972331c94a2e748afcaf87d6bd3f797f912d2fd12cb0dfb38bd74c58f WHIRLPOOL 69d7f8e83a51673e32a97f89aa93b9724258b4d1eae20333675bb61c0212a3fa36d0ffcb18821aa64c9bb5c4cda4e2a19ff684e27325e083c877352cee3f0413
+MISC metadata.xml 975 SHA256 5277b5bc45cb17a8e4ab761107181e8d96dbe4d22f04933574632acb42fa0ed9 SHA512 f72b79828ccfd7df1c7a9bbcd961dc73e57ece831ea97291efa52a484b97eb4fe1f7257aadc6a3bb70c7f9f36776b8ca296bedc43b5df86b17f6902a1ec33572 WHIRLPOOL 36e07509d7825822767bcff1f6eb2c3f30d0bcfd9848d4c3f5906f402320d74e1f88422fd8651955ffb9cb1d7feed41f1aaaae1de1039b8283f061e287178d44
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..5169a9e48f51
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="library for manipulating the International Press Telecommunications
+Council (IPTC) metadata"
+HOMEPAGE="http://libiptcdata.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 ia64 ppc ppc64 sparc x86"
+IUSE="doc examples nls python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.13.1 )
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure () {
+ econf \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable doc gtk-doc)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed."
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/python
+ doins python/README || die "doins failed"
+ doins -r python/examples || die "doins 2 failed"
+ fi
+
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+}
diff --git a/media-libs/libiptcdata/metadata.xml b/media-libs/libiptcdata/metadata.xml
new file mode 100644
index 000000000000..f6bb506c2b52
--- /dev/null
+++ b/media-libs/libiptcdata/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <longdescription lang="en">
+ libiptcdata is a library, written in C, for manipulating the
+ International Press Telecommunications Council (IPTC) metadata stored
+ within multimedia files such as images. This metadata can include
+ captions and keywords, often used by popular photo management
+ applications. The library provides routines for parsing, viewing,
+ modifying, and saving this metadata. The library is licensed under the
+ GNU Library General Public License (GNU LGPL). The libiptcdata package
+ also includes a command-line utility, iptc, for editing IPTC data in
+ JPEG files, as well as Python bindings.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">libiptcdata</remote-id>
+ </upstream>
+</pkgmetadata>