summaryrefslogtreecommitdiff
path: root/media-libs/libilbc/libilbc-3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /media-libs/libilbc/libilbc-3.0.4.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'media-libs/libilbc/libilbc-3.0.4.ebuild')
-rw-r--r--media-libs/libilbc/libilbc-3.0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/libilbc/libilbc-3.0.4.ebuild b/media-libs/libilbc/libilbc-3.0.4.ebuild
new file mode 100644
index 000000000000..9f2f31bf171f
--- /dev/null
+++ b/media-libs/libilbc/libilbc-3.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/TimothyGu/${PN}"
+else
+ SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
+HOMEPAGE="https://github.com/TimothyGu/libilbc"
+
+LICENSE="BSD"
+SLOT="0/3"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.4-respect-CFLAGS.patch"
+)