summaryrefslogtreecommitdiff
path: root/media-libs/libheif
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /media-libs/libheif
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'media-libs/libheif')
-rw-r--r--media-libs/libheif/Manifest4
-rw-r--r--media-libs/libheif/libheif-1.3.2.ebuild56
-rw-r--r--media-libs/libheif/libheif-9999.ebuild56
-rw-r--r--media-libs/libheif/metadata.xml11
4 files changed, 127 insertions, 0 deletions
diff --git a/media-libs/libheif/Manifest b/media-libs/libheif/Manifest
new file mode 100644
index 000000000000..70b45d460aa8
--- /dev/null
+++ b/media-libs/libheif/Manifest
@@ -0,0 +1,4 @@
+DIST libheif-1.3.2.tar.gz 1328174 BLAKE2B 4c0f82bb90d48f89a4ce9aed525c5823bb5d008e54e580e761f6fa4f5493f265929a0607e7b81046ba7c249bd2ca21a0c5ab91da83b7e7f3a2a63e8f24df88ed SHA512 bcc8b4b2522ef6fe68f5a9ffd5312c2c8f6bc3718394eef1860e199c30fb735bb214f665ed6480b5f5fe5d578b3ed77a4301af93775ae2349ba5038b3f3ef63a
+EBUILD libheif-1.3.2.ebuild 1320 BLAKE2B 59c0088337011cf9db2470f68a32f51d66e18fa09432f5ce75e4f01efe06c33d03cca73fe9910e1dbd2cf081ba87206146bc99809de895b8523522e42dd488c2 SHA512 2e3ed1301604c97c502b16977d7863b175703004193edf48dec44f9c029afdc69f800922da94c10322a9f76ac9f70dfc8f13dd30d573c51a2c5db2ddaec01730
+EBUILD libheif-9999.ebuild 1325 BLAKE2B b13d52b4593ca62e796208564edb6a6696e86bfe3d0539ca74277027de4d9db7b89867667fb29b9af1f5eed8c583d337b34ed6a4083292ba681963b5ed871fe1 SHA512 ede20f379e5807387acd892472f8190e7ba71a522b027e1297a37bd722832bff6125ad43a94ce5e0ee6d33ec5beb80b1e93793e27e5d2550c8e83f4db24f9504
+MISC metadata.xml 369 BLAKE2B e85296d149b4ebfe852a79ed951dff87e3586617cac09f2e81bc501f2739599e7fda1835f1d677cd923a1324e4f6d85e4f1552eb0589511372dd603d239880c5 SHA512 70bbaa03beb93f3649271be35d4c90e7d79395efefd0cfb9915525a5c736629bcf56bd66e2d1bbf2a746c62a5f21ddb8874cdf28f61180fe9abc3ad22ab51fc8
diff --git a/media-libs/libheif/libheif-1.3.2.ebuild b/media-libs/libheif/libheif-1.3.2.ebuild
new file mode 100644
index 000000000000..2bce8218a61a
--- /dev/null
+++ b/media-libs/libheif/libheif-1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.3"
+IUSE="static-libs +threads"
+
+# Doesn't yet support libjpeg-turbo-2, https://github.com/strukturag/libheif/issues/70
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ !>=media-libs/libjpeg-turbo-2
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable threads multithreading)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
new file mode 100644
index 000000000000..d9ed4b630621
--- /dev/null
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.3.9999"
+IUSE="static-libs +threads"
+
+# Doesn't yet support libjpeg-turbo-2, https://github.com/strukturag/libheif/issues/70
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ !>=media-libs/libjpeg-turbo-2
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable threads multithreading)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
diff --git a/media-libs/libheif/metadata.xml b/media-libs/libheif/metadata.xml
new file mode 100644
index 000000000000..22000d0b0b55
--- /dev/null
+++ b/media-libs/libheif/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/strukturag/libheif/issues</bugs-to>
+ <remote-id type="github">strukturag/libheif</remote-id>
+ </upstream>
+</pkgmetadata>