summaryrefslogtreecommitdiff
path: root/media-libs/libglvnd/libglvnd-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /media-libs/libglvnd/libglvnd-1.2.0.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'media-libs/libglvnd/libglvnd-1.2.0.ebuild')
-rw-r--r--media-libs/libglvnd/libglvnd-1.2.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/libglvnd/libglvnd-1.2.0.ebuild b/media-libs/libglvnd/libglvnd-1.2.0.ebuild
new file mode 100644
index 000000000000..c7d45b570081
--- /dev/null
+++ b/media-libs/libglvnd/libglvnd-1.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
+
+DESCRIPTION="The GL Vendor-Neutral Dispatch library"
+HOMEPAGE="https://github.com/NVIDIA/libglvnd"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/NVIDIA/${PN}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ !media-libs/mesa[-libglvnd(-)]
+ !<media-libs/mesa-19.2.0_rc1
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+src_prepare() {
+ default
+ [[ $PV = 9999* ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ myconf=(
+ --disable-headers
+ $(use_enable X x11)
+ $(use_enable X glx)
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_test() {
+ emake check
+}