summaryrefslogtreecommitdiff
path: root/media-libs/libglvnd/libglvnd-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-libs/libglvnd/libglvnd-1.1.1.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-libs/libglvnd/libglvnd-1.1.1.ebuild')
-rw-r--r--media-libs/libglvnd/libglvnd-1.1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/libglvnd/libglvnd-1.1.1.ebuild b/media-libs/libglvnd/libglvnd-1.1.1.ebuild
new file mode 100644
index 000000000000..89d10684b842
--- /dev/null
+++ b/media-libs/libglvnd/libglvnd-1.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
+
+DESCRIPTION="The GL Vendor-Neutral Dispatch library"
+HOMEPAGE="https://github.com/NVIDIA/libglvnd"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/NVIDIA/${PN}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ !media-libs/mesa[-libglvnd(-)]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ "
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}"
+
+src_prepare() {
+ default
+ [[ $PV = 9999* ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_test() {
+ emake check
+}