summaryrefslogtreecommitdiff
path: root/media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild')
-rw-r--r--media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild b/media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild
deleted file mode 100644
index d27cd8ed1912..000000000000
--- a/media-libs/libfreeaptx/libfreeaptx-0.1.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Reverse-engineered aptX and aptX HD library (fork of libopenaptx)"
-HOMEPAGE="https://github.com/iamthehorker/libfreeaptx"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/iamthehorker/${PN}"
-else
- SRC_URI="https://github.com/iamthehorker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ~ppc64 ~riscv x86"
-fi
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE="cpu_flags_x86_avx2"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-version.patch
-)
-
-src_compile() {
- tc-export CC AR
-
- use cpu_flags_x86_avx2 && append-cflags "-mavx2"
-
- emake \
- PREFIX="${EPREFIX}"/usr \
- LIBDIR=$(get_libdir) \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- ARFLAGS="${ARFLAGS} -rcs" \
- all
-}
-
-src_install() {
- emake \
- PREFIX="${EPREFIX}"/usr \
- DESTDIR="${D}" \
- LIBDIR="$(get_libdir)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- ARFLAGS="${ARFLAGS} -rcs" \
- install
-}