summaryrefslogtreecommitdiff
path: root/media-libs/libeot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /media-libs/libeot
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'media-libs/libeot')
-rw-r--r--media-libs/libeot/Manifest3
-rw-r--r--media-libs/libeot/libeot-0.01-r1.ebuild30
-rw-r--r--media-libs/libeot/libeot-9999.ebuild21
3 files changed, 42 insertions, 12 deletions
diff --git a/media-libs/libeot/Manifest b/media-libs/libeot/Manifest
index 268f38a23c42..b459add455c5 100644
--- a/media-libs/libeot/Manifest
+++ b/media-libs/libeot/Manifest
@@ -1,4 +1,5 @@
DIST libeot-0.01.tgz 38651 BLAKE2B ba8362035dca9db2adef636ce153f4fd1d75c20cf0f9671d6f1aa64e055dfbe7644811f44751e11eb4660f0902c14b66be8cdbb45c85325bfd5dd5b37e388b15 SHA512 ff8c3d92b948159171c76306d4a74758974c7ee26c801c5de48805f182b542015286b1e53cfc6dc4524494becb74fb55185701e06fc9be7c16f2d89ac0275941
+EBUILD libeot-0.01-r1.ebuild 639 BLAKE2B 730fe23ed3ee863294d8451b13b3355817b52dea751ab73e479fed87cf2f6c5beaa55796917dfcdc368e781ed4bfd775a752b7550631308ad7376525b9607529 SHA512 35942fc666b12b595e6fa12a75be90478141730e831936de2e8ec87be371ca34e9d7593d25ac500696e171eaff6b65d12a5f09a432894be1320b601107564ddb
EBUILD libeot-0.01.ebuild 706 BLAKE2B f4bf94c02c3d5211367050d5f122f55ee6f76dabd689e77dde3469a1c20ebb45c7bb6d257392a450d0e8f4a76632fd2c8151d5507998a169ecdf485f64a11ed0 SHA512 f3627131555a8bf5dd1a217e9cb368f86cf4c461515eddaaa8119a60334524bc07e24359a2a44b0a21a200eadd20e143661ab084e77f46aa8b1833763d6e0f9d
-EBUILD libeot-9999.ebuild 701 BLAKE2B f7b7bdbc3c61e3c6812fba7f02c080f8521acbfe01445eec5c6a533f537a3279aa03ca06a229167c3fb3c635d16edd89dace472973e148b89f6a1c55076ba227 SHA512 cc19cea0eb60270a72720ac199533e40a07dfdb793130c7171894c0779c6a76f085ff18fc035956f79f7a9f98beda87b030b609ccfd2685e76669cf9a728ade2
+EBUILD libeot-9999.ebuild 639 BLAKE2B 730fe23ed3ee863294d8451b13b3355817b52dea751ab73e479fed87cf2f6c5beaa55796917dfcdc368e781ed4bfd775a752b7550631308ad7376525b9607529 SHA512 35942fc666b12b595e6fa12a75be90478141730e831936de2e8ec87be371ca34e9d7593d25ac500696e171eaff6b65d12a5f09a432894be1320b601107564ddb
MISC metadata.xml 338 BLAKE2B c6c1ff67c503267257fab7101393f177a21a5a138d3cfb16c3fa4b08f091d176dcf1eeb1bd877d57925fec692bebaeb4c5ea6888022c02bb4f45c22ba3ac76a7 SHA512 a2156072b19db8ea245cf965854e79dde90ed7fac4ce4dba641ef081a0fef6d5dfe3e01c764ed83317d843f152976b31ab2bc9ff2a8a6a4357fa48701f4af927
diff --git a/media-libs/libeot/libeot-0.01-r1.ebuild b/media-libs/libeot/libeot-0.01-r1.ebuild
new file mode 100644
index 000000000000..62bab11bf0a5
--- /dev/null
+++ b/media-libs/libeot/libeot-0.01-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
+HOMEPAGE="https://github.com/umanwizard/libeot"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+else
+ SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libeot/libeot-9999.ebuild b/media-libs/libeot/libeot-9999.ebuild
index 91859a818b7e..62bab11bf0a5 100644
--- a/media-libs/libeot/libeot-9999.ebuild
+++ b/media-libs/libeot/libeot-9999.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
inherit autotools
-[[ ${PV} == 9999 ]] && inherit git-r3
DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
HOMEPAGE="https://github.com/umanwizard/libeot"
-[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+else
+ SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
LICENSE="MPL-2.0"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
src_prepare() {
default