summaryrefslogtreecommitdiff
path: root/media-libs/libeot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libeot
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libeot')
-rw-r--r--media-libs/libeot/Manifest5
-rw-r--r--media-libs/libeot/libeot-0.01.ebuild31
-rw-r--r--media-libs/libeot/libeot-9999.ebuild31
-rw-r--r--media-libs/libeot/metadata.xml11
4 files changed, 78 insertions, 0 deletions
diff --git a/media-libs/libeot/Manifest b/media-libs/libeot/Manifest
new file mode 100644
index 000000000000..a26e0a62679d
--- /dev/null
+++ b/media-libs/libeot/Manifest
@@ -0,0 +1,5 @@
+DIST libeot-0.01.tgz 38651 SHA256 6f76f57b7819885e4dc4ca278eaef8ba332bef278ee757e3aea2b8d85d06b4bb SHA512 ff8c3d92b948159171c76306d4a74758974c7ee26c801c5de48805f182b542015286b1e53cfc6dc4524494becb74fb55185701e06fc9be7c16f2d89ac0275941 WHIRLPOOL 38d1d7e0a5ccc3a3dd6e76423bc1ad18b11b10dcf3bd339f0aa657b96bafa565082a939680d9a0b9764099d34fb0813e3a4cea4217374ec437b371a897664776
+EBUILD libeot-0.01.ebuild 694 SHA256 61d4ac883555e6cbc34a86450608b940677268338b20454ede17f71e98bf76f9 SHA512 1b9c3b38e44c902a9c058074fa6bbe5d68a9a32c86075b9a1d20c465e876b128701e46f5c2a7c9526392b5b264dc9726857ea88819e060d8636017a1c2af0117 WHIRLPOOL b14e16f652cd6dda97807bacf13ffae17e9c17f5fac707a084279308fa400e19bb11d259f096bd2b89445467daeb94b32db18c29d52a97119dcad21bc82ecebf
+EBUILD libeot-9999.ebuild 696 SHA256 b9447e863ec54f9ecc2b82448d5ae7770a0e61a85036de16cec4129d44551eda SHA512 a06a1b5cc415f4550306cf845fddfed4330ab67214490504b6b96f10ba11e626a29cd41630aeb768b7e912b466a563329d6241b255669bd49d553b4e9d630c85 WHIRLPOOL 51fa7a5bc59fd885bb2605fa4f007862854ae6902bfb39cfc54d27bf0bbab655c7de90570335b8e156cb187d84f780e8b7614b0947e018ba47933c3c2f710a8a
+MISC ChangeLog 391 SHA256 632bc0996c0a8618fe91b242bf2a8e8de5484aa716ee8c7d122bdfbf56259575 SHA512 2d7259acf30776c73c1246cd19e30583f9f233c23aad656653d0f9c059caba0237b73444624320b46c46bcc952dd2e8af59881d763ec0dda5a389646ea2c9144 WHIRLPOOL c80d538e22c66ee3d0e7f44620d0677e8cdc2c114dcf6fd30317475d274d57ea25f0ca387b1bb776f361d6b40b3e2b25ab3529300aa823745cc3ecd930f581b0
+MISC metadata.xml 337 SHA256 b4c40ebad302e8f439d0886a368872f26b815607d6b75cc8d2a47661eff7380b SHA512 f6e8f0e47210206c618ed9d2bbd96bb8837ca31f33ccab14ee487f9922f079f404ddedd563e4213f551aefa3216291189bb89da61a0ece6ed27094ae8226063a WHIRLPOOL fa3d739caabe8afd0bf202c55825ff439042fe3dd621dc6107b475894791774b6d12e0ae20e1f3eefca84b8ad1f94cde9b8c6899c9e6061d90ceb3b5b12a7c2d
diff --git a/media-libs/libeot/libeot-0.01.ebuild b/media-libs/libeot/libeot-0.01.ebuild
new file mode 100644
index 000000000000..94176cfe566e
--- /dev/null
+++ b/media-libs/libeot/libeot-0.01.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+inherit eutils autotools
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
+HOMEPAGE="https://github.com/umanwizard/libeot"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libeot/libeot-9999.ebuild b/media-libs/libeot/libeot-9999.ebuild
new file mode 100644
index 000000000000..b5fcbe1194d9
--- /dev/null
+++ b/media-libs/libeot/libeot-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+inherit eutils autotools
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
+HOMEPAGE="https://github.com/umanwizard/libeot"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libeot/metadata.xml b/media-libs/libeot/metadata.xml
new file mode 100644
index 000000000000..1064a16ef160
--- /dev/null
+++ b/media-libs/libeot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">umanwizard/libeot</remote-id>
+ </upstream>
+</pkgmetadata>