summaryrefslogtreecommitdiff
path: root/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
commita833e3f4a431b8eea751b7420e127787f9c92117 (patch)
treeb941d23e9e3d5f070b01feb15ef927839af7456a /media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
parent4cd2370bed609c118b6edfde5d3f116e5c35b897 (diff)
gentoo resync : 04.12.2017
Diffstat (limited to 'media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild')
-rw-r--r--media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild b/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
new file mode 100644
index 000000000000..8c96eb334aa0
--- /dev/null
+++ b/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free implementation of the DVB Common Scrambling Algorithm - DVB/CSA"
+HOMEPAGE="https://www.videolan.org/developers/libdvbcsa.html"
+SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug cpu_flags_x86_mmx cpu_flags_x86_sse2 static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable ppc altivec) \
+ $(use_enable debug) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable static-libs static) \
+ $(use_enable x86 uint32) \
+ $(use_enable amd64 uint64) \
+ --enable-shared
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}