summaryrefslogtreecommitdiff
path: root/media-libs/libdv/files/libdv-1.0.0-darwin.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /media-libs/libdv/files/libdv-1.0.0-darwin.patch
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'media-libs/libdv/files/libdv-1.0.0-darwin.patch')
-rw-r--r--media-libs/libdv/files/libdv-1.0.0-darwin.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libdv/files/libdv-1.0.0-darwin.patch b/media-libs/libdv/files/libdv-1.0.0-darwin.patch
new file mode 100644
index 000000000000..c6d48d5a6949
--- /dev/null
+++ b/media-libs/libdv/files/libdv-1.0.0-darwin.patch
@@ -0,0 +1,52 @@
+* grobian@gentoo.org: Darwin 8 lacks sched_setscheduler
+
+https://sourceforge.net/tracker/index.php?func=detail&aid=2606558&group_id=4393&atid=304393
+
+--- configure.ac
++++ configure.ac
+@@ -244,7 +244,7 @@
+
+ dnl Checks for library functions.
+ AC_FUNC_MMAP
+-AC_CHECK_FUNCS(gettimeofday)
++AC_CHECK_FUNCS(gettimeofday sched_get_priority_max sched_setscheduler)
+
+ AC_SUBST(ac_aux_dir)
+ AC_SUBST(RPM_RELEASE)
+--- configure
++++ configure
+@@ -22621,7 +22621,7 @@
+ rm -f conftest.mmap
+
+
+-for ac_func in gettimeofday
++for ac_func in gettimeofday sched_get_priority_max sched_setscheduler
+ do
+ as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ { echo "$as_me:$LINENO: checking for $ac_func" >&5
+--- config.h.in
++++ config.h.in
+@@ -24,6 +24,12 @@
+ /* Define to 1 if you have the `gettimeofday' function. */
+ #undef HAVE_GETTIMEOFDAY
+
++/* Define to 1 if you have the `sched_get_priority_max' function. */
++#undef HAVE_SCHED_GET_PRIORITY_MAX
++
++/* Define to 1 if you have the `sched_setscheduler' function. */
++#undef HAVE_SCHED_SETSCHEDULER
++
+ /* Define as 1 if you have gtk */
+ #undef HAVE_GTK
+
+--- encodedv/dvconnect.c
++++ encodedv/dvconnect.c
+@@ -860,7 +860,7 @@
+
+ int rt_raisepri (int pri)
+ {
+-#ifdef _SC_PRIORITY_SCHEDULING
++#if defined(_SC_PRIORITY_SCHEDULING) && defined(HAVE_SCHED_GET_PRIORITY_MAX) && defined(HAVE_SCHED_SETSCHEDULER)
+ struct sched_param scp;
+
+ /*