summaryrefslogtreecommitdiff
path: root/media-libs/libdca/libdca-0.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-libs/libdca/libdca-0.0.7.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-libs/libdca/libdca-0.0.7.ebuild')
-rw-r--r--media-libs/libdca/libdca-0.0.7.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/libdca/libdca-0.0.7.ebuild b/media-libs/libdca/libdca-0.0.7.ebuild
new file mode 100644
index 000000000000..0e794c3f2109
--- /dev/null
+++ b/media-libs/libdca/libdca-0.0.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="Library for decoding DTS Coherent Acoustics streams used in DVD"
+HOMEPAGE="https://www.videolan.org/developers/libdca.html"
+SRC_URI="https://www.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="debug oss"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO doc/${PN}.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.5-cflags.patch
+ "${FILESDIR}"/${PN}-0.0.5-tests-optional.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ append-lfs-flags #328875
+
+ local myeconfargs=(
+ --disable-static
+ $(use_enable debug)
+ $(use_enable oss)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+
+ # Those are thrown away afterwards, don't build them in the first place
+ if [[ "${ABI}" != "${DEFAULT_ABI}" ]] ; then
+ sed -e 's/ libao src//' -i Makefile || die
+ fi
+}
+
+multilib_src_compile() {
+ emake OPT_CFLAGS=""
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ find "${D}" -name '*.la' -type f -delete || die
+ rm "${D}"/usr/$(get_libdir)/libdts.a || die
+}