summaryrefslogtreecommitdiff
path: root/media-libs/libbdplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /media-libs/libbdplus
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'media-libs/libbdplus')
-rw-r--r--media-libs/libbdplus/Manifest3
-rw-r--r--media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild47
-rw-r--r--media-libs/libbdplus/libbdplus-9999.ebuild36
3 files changed, 73 insertions, 13 deletions
diff --git a/media-libs/libbdplus/Manifest b/media-libs/libbdplus/Manifest
index 33e87d2c3f09..0b29c9bcb853 100644
--- a/media-libs/libbdplus/Manifest
+++ b/media-libs/libbdplus/Manifest
@@ -1,4 +1,5 @@
DIST libbdplus-0.1.2.tar.bz2 319828 BLAKE2B bdf8868dc511b22fd6926b4b29cfae513ca5c9f30433314c99bf31aefb5842eea1042e514383d1c1ff96ee6c62f3220a542973eb1017df8dd48aecd7f81237ac SHA512 e00e7bc9f52b9275646593b753ba646b052255be94a7241965f4dbe4734f8f6a072973ed4b9997957f939236b0633897c295749f79e232188430795be5b5087b
+EBUILD libbdplus-0.1.2-r1.ebuild 1055 BLAKE2B 7ab0d4a78535a37eb69577e0bca7af7302928fb37badcbc95d8ae2f3e3ffa632ff2492f3da201e0c586233db3daf06bf26802391dfd6c876b50f0e0cae8b1969 SHA512 18bc5be6402b1dae1324f0f2b7999cbdd502964f307d89add25e42d660f534bb01ee9c403f5d36ebf09f85ca653ef4509d82f2b7e3218ab01af9124f2e8b0b87
EBUILD libbdplus-0.1.2.ebuild 878 BLAKE2B 831c09aab8f391d25826ca803514f464f02c516e45bcb056b22f8abd09eb3d19f00295a88d1b911942a5698d23ac856e2c24abe5c88cfcc6d1052cd752005f06 SHA512 52a573e72e3f73be093a99582cdd4f5b1284f140502b9fffeea3d625483e89db0eb23cbcd9e17450dfd3c30c7d4f1aaac380faf8aeb099a72a25be5a5d5d514d
-EBUILD libbdplus-9999.ebuild 864 BLAKE2B c0edddfcb68340cfaec615269079d71ebd873f7c4c720cc194fee6be460f928053852f9d278064ae27685cfbf7beedb198c4f17fb8a30100e21717571f2f4ec2 SHA512 ddd680235bbdc7d40b7fb6da460680aca623c4caa28742e7700380eaf232d71b8dc5d7e6f6fe67b25fc2f84c851e8e83f97ac0d68f601194e3b8b31585027afa
+EBUILD libbdplus-9999.ebuild 1055 BLAKE2B 7ab0d4a78535a37eb69577e0bca7af7302928fb37badcbc95d8ae2f3e3ffa632ff2492f3da201e0c586233db3daf06bf26802391dfd6c876b50f0e0cae8b1969 SHA512 18bc5be6402b1dae1324f0f2b7999cbdd502964f307d89add25e42d660f534bb01ee9c403f5d36ebf09f85ca653ef4509d82f2b7e3218ab01af9124f2e8b0b87
MISC metadata.xml 346 BLAKE2B 7a42d692f3ccc8badbed9bc2d06f4b06891f0fc46d53501de443dbff04b71c6db74f78a310cd484945be3b2035ae001804443bff1a18dcd5b0ef24474453910e SHA512 c45e738ea1fa2ff40738465bcafc8b6c89e7d5dfd3c89250118bc3c531120ee14022c04fe0a2bd5cbe950dd66935be35254239fc61eb947b597328809735693f
diff --git a/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild b/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..8bffc8107314
--- /dev/null
+++ b/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Blu-ray library for BD+ decryption"
+HOMEPAGE="https://www.videolan.org/developers/libbdplus.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aacs"
+
+RDEPEND="
+ dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ dev-libs/libgpg-error[${MULTILIB_USEDEP}]
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ --disable-static
+ $(use_with aacs libaacs)
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/media-libs/libbdplus/libbdplus-9999.ebuild b/media-libs/libbdplus/libbdplus-9999.ebuild
index 5525e10aec4f..8bffc8107314 100644
--- a/media-libs/libbdplus/libbdplus-9999.ebuild
+++ b/media-libs/libbdplus/libbdplus-9999.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools-multilib
+EAPI=7
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
+inherit multilib-minimal
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit autotools git-r3
EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
else
SRC_URI="https://downloads.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
fi
DESCRIPTION="Blu-ray library for BD+ decryption"
@@ -17,19 +18,30 @@ HOMEPAGE="https://www.videolan.org/developers/libbdplus.html"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="aacs static-libs"
+IUSE="aacs"
-RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+RDEPEND="
+ dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
dev-libs/libgpg-error[${MULTILIB_USEDEP}]
- aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
+"
DEPEND="${RDEPEND}"
-DOCS="ChangeLog README.txt"
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
-src_configure() {
+multilib_src_configure() {
local myeconfargs=(
--disable-optimizations
+ --disable-static
$(use_with aacs libaacs)
)
- autotools-multilib_src_configure
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name "*.la" -delete || die
}