summaryrefslogtreecommitdiff
path: root/media-libs/libbdplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/libbdplus
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/libbdplus')
-rw-r--r--media-libs/libbdplus/Manifest4
-rw-r--r--media-libs/libbdplus/libbdplus-0.2.0.ebuild49
-rw-r--r--media-libs/libbdplus/libbdplus-9999.ebuild12
3 files changed, 59 insertions, 6 deletions
diff --git a/media-libs/libbdplus/Manifest b/media-libs/libbdplus/Manifest
index 3e826b81b29d..3e9211a482e8 100644
--- a/media-libs/libbdplus/Manifest
+++ b/media-libs/libbdplus/Manifest
@@ -1,4 +1,6 @@
DIST libbdplus-0.1.2.tar.bz2 319828 BLAKE2B bdf8868dc511b22fd6926b4b29cfae513ca5c9f30433314c99bf31aefb5842eea1042e514383d1c1ff96ee6c62f3220a542973eb1017df8dd48aecd7f81237ac SHA512 e00e7bc9f52b9275646593b753ba646b052255be94a7241965f4dbe4734f8f6a072973ed4b9997957f939236b0633897c295749f79e232188430795be5b5087b
+DIST libbdplus-0.2.0.tar.bz2 321743 BLAKE2B 2ef8da1741829aef1e0e52fda3ef4d41d05fc7141d1e38c0e8bbdf116fe7afa65024c9d97f61e5ec9ccdf5d2d6063a4d1aff2a0731e7f19b280e31f1b637a9c2 SHA512 172e4932fb5540fbdb5b86e1d42cfaddf60b81416d2de50c8add83fb7f1bd7c296c975fd84a6ec42566977086dccfe07db5ce696038862bc75c6494c647998d6
EBUILD libbdplus-0.1.2-r1.ebuild 1050 BLAKE2B 10a40ea3e988f632026a315dbde1d4527578fe6ce681b3b12af65aa90473bec0a6829150a9f736721f261c0c73e890b654dce2cb496982261ac770e85952fb33 SHA512 b9066a5d1a0d9833e8b466375906e0f23b685ad91493f5c5e6b8a26bf03241e26f3864512591915990a34f2960eccb345c6fdea08ca6cfa101a5dff6f911bdfd
-EBUILD libbdplus-9999.ebuild 1055 BLAKE2B 7ab0d4a78535a37eb69577e0bca7af7302928fb37badcbc95d8ae2f3e3ffa632ff2492f3da201e0c586233db3daf06bf26802391dfd6c876b50f0e0cae8b1969 SHA512 18bc5be6402b1dae1324f0f2b7999cbdd502964f307d89add25e42d660f534bb01ee9c403f5d36ebf09f85ca653ef4509d82f2b7e3218ab01af9124f2e8b0b87
+EBUILD libbdplus-0.2.0.ebuild 1040 BLAKE2B af69923a82128d5ac6c8028107995921bd80d44c2f2cb0d5ddc4afdc58122bc0a2499ca563f4d93845f6a6be274357b01e285d6e8500a8e9123ffe343230db2d SHA512 41f82471a7b3b1a85a0dff09712c2928f4a5a4734f4496d913b7bf3657c0ddcafa585d9f3a5cde82d09426318b9bad285c3a80dc1705ebbb1d01fe09eb72686c
+EBUILD libbdplus-9999.ebuild 1040 BLAKE2B af69923a82128d5ac6c8028107995921bd80d44c2f2cb0d5ddc4afdc58122bc0a2499ca563f4d93845f6a6be274357b01e285d6e8500a8e9123ffe343230db2d SHA512 41f82471a7b3b1a85a0dff09712c2928f4a5a4734f4496d913b7bf3657c0ddcafa585d9f3a5cde82d09426318b9bad285c3a80dc1705ebbb1d01fe09eb72686c
MISC metadata.xml 347 BLAKE2B 8db9fe97341f2b23aea662c6a416c7fa0c4a6c593afb3ed4c55f20326b07a03d909b0d23055c37eccbf44f53098542d273198d97e95ceb425172c050e0dc03c5 SHA512 96b0fba6ce8a9fe073ce96f18fcca7961b682c6f5c2839992bb323fbfd3984bdcb234ae475914055b4336002825e7c9e4ba6ab673e9c2dfeebbd6dce8880e499
diff --git a/media-libs/libbdplus/libbdplus-0.2.0.ebuild b/media-libs/libbdplus/libbdplus-0.2.0.ebuild
new file mode 100644
index 000000000000..42d90708b4cc
--- /dev/null
+++ b/media-libs/libbdplus/libbdplus-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Blu-ray library for BD+ decryption"
+HOMEPAGE="https://www.videolan.org/developers/libbdplus.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aacs"
+
+RDEPEND="
+ dev-libs/libgcrypt:=[${MULTILIB_USEDEP}]
+ dev-libs/libgpg-error[${MULTILIB_USEDEP}]
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ $(use_with aacs libaacs)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/media-libs/libbdplus/libbdplus-9999.ebuild b/media-libs/libbdplus/libbdplus-9999.ebuild
index 8bffc8107314..42d90708b4cc 100644
--- a/media-libs/libbdplus/libbdplus-9999.ebuild
+++ b/media-libs/libbdplus/libbdplus-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-minimal
@@ -21,7 +21,7 @@ SLOT="0"
IUSE="aacs"
RDEPEND="
- dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ dev-libs/libgcrypt:=[${MULTILIB_USEDEP}]
dev-libs/libgpg-error[${MULTILIB_USEDEP}]
aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
"
@@ -29,19 +29,21 @@ DEPEND="${RDEPEND}"
src_prepare() {
default
+
[[ ${PV} == 9999 ]] && eautoreconf
}
multilib_src_configure() {
local myeconfargs=(
--disable-optimizations
- --disable-static
$(use_with aacs libaacs)
)
- ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
+
find "${ED}" -type f -name "*.la" -delete || die
}