summaryrefslogtreecommitdiff
path: root/media-libs/lensfun/lensfun-0.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 01:58:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 01:58:14 +0000
commit4921f12d049de1487e17383a32da50a03ea90d65 (patch)
treef96cddb6d290801562042528ed52a4a95d24afd1 /media-libs/lensfun/lensfun-0.3.2-r1.ebuild
parent7ef0a54f9e5cc53b6f0eb75144a94d0ad98aeef5 (diff)
gentoo auto-resync : 23:12:2022 - 01:58:14
Diffstat (limited to 'media-libs/lensfun/lensfun-0.3.2-r1.ebuild')
-rw-r--r--media-libs/lensfun/lensfun-0.3.2-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/media-libs/lensfun/lensfun-0.3.2-r1.ebuild b/media-libs/lensfun/lensfun-0.3.2-r1.ebuild
deleted file mode 100644
index 0cf6eb2b6e13..000000000000
--- a/media-libs/lensfun/lensfun-0.3.2-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit python-single-r1 cmake
-
-DESCRIPTION="Library for rectifying and simulating photographic lens distortions"
-HOMEPAGE="https://lensfun.github.io"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3 CC-BY-SA-3.0" # See README for reasoning.
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc cpu_flags_x86_sse cpu_flags_x86_sse2 test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- doc? (
- app-doc/doxygen
- dev-python/docutils
- )
-"
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.40
- media-libs/libpng:0=
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md docs/mounts.txt ChangeLog )
-
-PATCHES=(
- "${FILESDIR}/${P}-warnings.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
- -DSETUP_PY_INSTALL_PREFIX="${ED}"/usr
- -DBUILD_LENSTOOL=ON
- -DBUILD_STATIC=OFF
- -DBUILD_DOC=$(usex doc)
- -DBUILD_FOR_SSE=$(usex cpu_flags_x86_sse)
- -DBUILD_FOR_SSE2=$(usex cpu_flags_x86_sse2)
- -DBUILD_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- mkdir -p "${T}/db/lensfun" || die
- cp data/db/* "${T}/db/lensfun/" || die
-
- XDG_DATA_HOME="${T}/db" cmake_src_test
-}
-
-src_install() {
- cmake_src_install
- python_optimize
-}