summaryrefslogtreecommitdiff
path: root/media-libs/kcolorpicker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /media-libs/kcolorpicker
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'media-libs/kcolorpicker')
-rw-r--r--media-libs/kcolorpicker/Manifest3
-rw-r--r--media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild41
-rw-r--r--media-libs/kcolorpicker/metadata.xml16
3 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/kcolorpicker/Manifest b/media-libs/kcolorpicker/Manifest
new file mode 100644
index 000000000000..bf22ea47c958
--- /dev/null
+++ b/media-libs/kcolorpicker/Manifest
@@ -0,0 +1,3 @@
+DIST kColorPicker-0.1.4.tar.gz 11438 BLAKE2B 407211d5938d78aa8bfe193c037a3224ab51cacec7213e4526689ba38a800db2f5df4b0804cd3cc428765a22f426b50d870a355ce07d3f40ff231b8d4f44bf93 SHA512 135b8e0e189feb724f6a4f6a09b8e18922d294fbb3c80cd8522acec272ad0503eff5bf375ae7d58b1dd2f891dc0df187b2a3442726f8ff980583c475090b8673
+EBUILD kcolorpicker-0.1.4.ebuild 724 BLAKE2B 5541e6a84569d0b80a8306a84e3e73f24b0a780534e052f9f64c0df40188adf784f7ccad41d180e0532f4c962d61cd2ed2b88407efd1b37a9bbcab908d8a532b SHA512 24a88a49805019249934d7c1ba874072d782ce7b604cba693d5ab4318de66ccc62d3b73ec8cbf305a5cf9f86f7923495d4dcc676169bb6cf66775c54c189d47a
+MISC metadata.xml 582 BLAKE2B 5cabe4fbc89f6b33dd2193707ce455544c8e61139ea78d03220a4acb6833d7d085c8d3470ab0031ead6072d766987b93b4e1f15694898f25b8358bf550868598 SHA512 1b722a703324f146d71a8cbcf807b1e8be67708bbb3af541dbbe1e42958c9f47d5eca36e93f967521f37a2b674068265e7d2c2c7853aaeddfb93748b83794c8b
diff --git a/media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild b/media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild
new file mode 100644
index 000000000000..4867e8b9369d
--- /dev/null
+++ b/media-libs/kcolorpicker/kcolorpicker-0.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kColorPicker
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt based color picker with popup menu"
+HOMEPAGE="https://github.com/ksnip/kColorPicker"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5[png]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
diff --git a/media-libs/kcolorpicker/metadata.xml b/media-libs/kcolorpicker/metadata.xml
new file mode 100644
index 000000000000..e8952720fcef
--- /dev/null
+++ b/media-libs/kcolorpicker/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dflogeras2@gmail.com</email>
+ <name>David Flogeras</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">QToolButton with color popup menu with lets you
+ select a color. The popup features a color dialog button which can be
+ used to add custom colors to the popup menu.
+ </longdescription>
+</pkgmetadata>