summaryrefslogtreecommitdiff
path: root/media-libs/jg/jg-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /media-libs/jg/jg-1.0.0.ebuild
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'media-libs/jg/jg-1.0.0.ebuild')
-rw-r--r--media-libs/jg/jg-1.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/jg/jg-1.0.0.ebuild b/media-libs/jg/jg-1.0.0.ebuild
new file mode 100644
index 000000000000..9f2cd2137949
--- /dev/null
+++ b/media-libs/jg/jg-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference Implementation of The Jolly Good API"
+HOMEPAGE="https://jgemu.gitlab.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZLIB"
+SLOT="1"
+
+src_compile() {
+ : # Nothing to do
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+}