summaryrefslogtreecommitdiff
path: root/media-libs/gst-rtsp-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-libs/gst-rtsp-server
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-libs/gst-rtsp-server')
-rw-r--r--media-libs/gst-rtsp-server/Manifest2
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.14.5.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index 81e614273b6e..1d0483155880 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1,3 +1,5 @@
DIST gst-rtsp-server-1.14.2.tar.xz 665904 BLAKE2B 3f9ab3c1579d34ec8877bcc6da2802cc69aa444ef1fabfe548e2acf3b1c58eb0e29ffb09c250fb6d2ae61e4847bf2098c22874ec43266d46d5b402cbbbcda892 SHA512 81c64c31cef45479ec23d57b11d09950ca8c04820b6cf422af6caabccd71ad648e210a114f9f020136ddfdfc9e942c3eb15f055778d493d54c8770ed4f93634c
+DIST gst-rtsp-server-1.14.5.tar.xz 672180 BLAKE2B 3e67f703c190e46580cf7c08a9437d51e9c1e009dd27cf359ecd5aa301ddda6cd70c0d5567e72c6e5f9443318e899a9b55e6883c71c9fc021f77286afd89bbc9 SHA512 dbfb63fb219808d2a32d710bef33d2b3b9906300d4c527c72534a4cb6db0f5ce4f4fadcedf7f6a3a5f46005f4408717d9aafa1a510c4aed18f5d07d6b3646492
EBUILD gst-rtsp-server-1.14.2.ebuild 1983 BLAKE2B 44bbb19d0691a24c72f5dd0237fbfecfc6aaf89d6dbc3d346e4bf828ee0543427da5df4c443bd2c634a56716ebff70c67c8edac30f586cd5ecbf607854749a1e SHA512 9f3e868ca8b2aff1d64ba01a6747268643c2c98304db63a117c18c9250af699dcbf3854390c320d05e8620807ca08bb4994f8822ceb09a0fdfbfb73077cdde8f
+EBUILD gst-rtsp-server-1.14.5.ebuild 1985 BLAKE2B 385b06fef47504a0b5ee5435d09de826b1594bc9ee1371ca440c4bcebb5e16a4d3d7a285bbc7968c500550e55ac2a5e2d54f77467b549ea25e5f76d240d96674 SHA512 c4f3d1be98944daae9b9251f5a48436cc03eefc886b99935dff42ffd121c5217e465d2e9e016790d8318940341db8c9df5ef0045ea6a668483a8aa986d5fab58
MISC metadata.xml 262 BLAKE2B 16a4a230ef5481afde96333e9555bee1771ced412b11eb982c633709dec57b274f78082ba3fe842f7d3406a688662d34792fff304027833286b30652e9982719 SHA512 608f0a17d576a3b23a6921272eb449a6efed76b3c4b3fdf8737b2d499b56d109186c2883c06e5c843799d2fb1606f3066c43759b40f9d7cf58b6a674c38dd0e0
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.14.5.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.14.5.ebuild
new file mode 100644
index 000000000000..e31415b887ee
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.14.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs test"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+multilib_src_configure() {
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behind that switch
+ # libcgroup is automagic and only used in examples
+ gstreamer_multilib_src_configure \
+ --disable-debug \
+ --disable-valgrind \
+ --disable-examples \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ LIBCGROUP_LIBS= \
+ LIBCGROUP_FLAGS=
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}