summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild
new file mode 100644
index 000000000000..5d44634e14dc
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-ugly"
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit gstreamer-meson python-any-r1
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
+
+IUSE="+orc"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}