summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-bad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /media-libs/gst-plugins-bad
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/Manifest4
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.18.4.ebuild79
-rw-r--r--media-libs/gst-plugins-bad/metadata.xml2
3 files changed, 84 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index 1c0799371155..aa8ba0ce5633 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -1,3 +1,5 @@
DIST gst-plugins-bad-1.16.3.tar.xz 4900188 BLAKE2B 7d8280a434adb1cb65b065dcdabdb37aad000802c011bb27779c109978d8b75aa4e2fa47043dde95464bb0c34a0d7466dc1f6216f29f0f4911f7a6fe1fb04b25 SHA512 378d8813ba2fd61ea2cab512d5c1fa81e0a4ac4f4ca756547d9b8742e56024c1bc5d6cd332798de66ecfe2b69485c860e181a6c2090398b0e2ad8c4b3fe95d04
+DIST gst-plugins-bad-1.18.4.tar.xz 5640292 BLAKE2B 5385abe635a35f61c6780e6cfa1189835877b8c0a12145de6890708a097fc453b1abfb14a3497cae4e6961f71fc2c6e01759fe19386cd30a64c4069704ddf77a SHA512 02123e054419f5ce6ca2ebe0bdf23572269ea4120bf463b4d672efbe5d9e5d417d4d711cc80094be974c4569f754d8b2ad93f59b827e3b018d450582834cb125
EBUILD gst-plugins-bad-1.16.3.ebuild 2204 BLAKE2B 4997f2c2c124f632229b3dbe185f553b53be5419d00479d4b9c712bade33bc4558800c9e64648e603cb007f2fc6bf9c67f25cc8215e66e65e32e579c373c2eed SHA512 a508b1e0d2521cbc35ddeeef9fee6a46d89d9c9670a8037875573cd34492acd2a222bd95d09e78dfd4996c977e81ec71ba382f6c68578d7e6dbb15d95653255a
-MISC metadata.xml 345 BLAKE2B 2350705c0853758df34ef4e9217585b367adfa6f7a166e884c3e40a10cb2917b6c10dcc4438f41cd404337f70a9438114cfe7f301848637dddff626d8c25449e SHA512 26921a7928b3d70098a9f9d36c3f211a6e96df6ca42473ba98e083a52b2f9ab00a71336c0298751b9b46198f2277dada4db8097c0a4b09850e5ecd1a15db5436
+EBUILD gst-plugins-bad-1.18.4.ebuild 2283 BLAKE2B e8b5e6a9e096ca4a80b2b4528e7039eff1c9452028b40940afdd3f2761a5b444c80f25553a88f9ece038b305ec03f3d7652848edbf5d65aa2c7e959c1e80d197 SHA512 7172d2c14973d58c169d2b6a9ce58111a5af2cd70007fff14421b4b316139a2009bf6484d858ea4e55ab53fa06806f810de208ff7110ed26120e62f546c7b0a6
+MISC metadata.xml 439 BLAKE2B 5a4a36ccf4bd485eaf1fa66650eec8fa592d4c5bbf9fa478f1645e1b39649b7115694bf55dee7aeb4a5c53b2ba3c4614591cdf4e7d745938397c304108e0aa7c SHA512 9bd27a1a513fc2d697f7d0f2ceb7fa0701c446fe21b597256afd4c2c1f44145e875323ed1ef6202bf7b85472ab4aab43a4b6db5795bb1d28ff53a2a7e484055e
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.18.4.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.18.4.ebuild
new file mode 100644
index 000000000000..7e613b0fa6d4
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.18.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-bad"
+
+inherit flag-o-matic gstreamer-meson
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# TODO: egl and gtk IUSE only for transition
+IUSE="X bzip2 +egl gles2 gtk +introspection +opengl +orc vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
+
+# X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
+# We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
+# FIXME gtk? ( >=media-plugins/gst-plugins-gtk-${PV}:${SLOT}[${MULTILIB_USEDEP}] )
+RDEPEND="
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
+ wayland? (
+ >=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.4
+ )
+
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+"
+
+# FIXME: gstharness.c:889:gst_harness_new_with_padnames: assertion failed: (element != NULL)
+RESTRICT="test"
+
+src_prepare() {
+ default
+ addpredict /dev # Prevent sandbox violations bug #570624
+}
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="shm ipcpipeline librfb hls"
+ local emesonargs=(
+ -Dshm=enabled
+ -Dipcpipeline=enabled
+ -Dhls=disabled
+ $(meson_feature vnc librfb)
+
+ $(meson_feature wayland)
+ )
+
+ if use opengl || use gles2; then
+ myconf+=( -Dgl=enabled )
+ else
+ myconf+=( -Dgl=disabled )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_test() {
+ # Tests are slower than upstream expects
+ CK_DEFAULT_TIMEOUT=300 gstreamer_multilib_src_test
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/gst-plugins-bad/metadata.xml b/media-libs/gst-plugins-bad/metadata.xml
index ad9bf185482b..c51baf610a15 100644
--- a/media-libs/gst-plugins-bad/metadata.xml
+++ b/media-libs/gst-plugins-bad/metadata.xml
@@ -7,5 +7,7 @@
</maintainer>
<use>
<flag name="bzip2">Enable bzip2 encoder/decoder plugin</flag>
+ <flag name="egl">Enable EGL support</flag>
+ <flag name="gles2">Enable GLES2 support</flag>
</use>
</pkgmetadata>