summaryrefslogtreecommitdiff
path: root/media-libs/grilo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-libs/grilo
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/Manifest2
-rw-r--r--media-libs/grilo/grilo-0.3.9.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/grilo/Manifest b/media-libs/grilo/Manifest
index b1e0b9513837..1a4488ad1954 100644
--- a/media-libs/grilo/Manifest
+++ b/media-libs/grilo/Manifest
@@ -1,3 +1,5 @@
DIST grilo-0.3.7.tar.xz 232544 BLAKE2B 2d1f7942b09808bb5e09040b4a633a6bd354220ba1369d31ff6160c12ab15c1e2642617ae7f35c8320d7a5842736d8714c6e7dc7f3cb0651d841b6513633f5c9 SHA512 82c41d63edc23c056e189a73b0de87db342bba575d42efeda78ed4bf78fb8994111a2e9457e6f2453045b9b7b2d171b9e89d71c3a107cfa06af24644d9cb71df
+DIST grilo-0.3.9.tar.xz 233616 BLAKE2B c22b868d5bcb6731024b212d6bc1502b493950e363127202ded0ed80f3e937bf78062ba6f2803e29f686ff8cfc521147e69b8f4a7b33060d81e30f34a231e37b SHA512 250596f277ea76d8f6a071fb0e48dd7ea735a534f48a4f2e3f69f7c62a2b5b4c995714a8435ffa9107345e86bba5b21fc136cc47b956f461723a00d0e6ede9bf
EBUILD grilo-0.3.7.ebuild 2053 BLAKE2B 13132593347bd779208414302a0268478867e98ac583673bcb71608f9c72c420e9dae73025bbb5e33994e6ef6c0c3d27c53bd2ed46802df80a10661c6255f23e SHA512 3ec448ba94ee9206379ca5f7676e14471a472ae761edd077ec306fb9aa48841ca4e342fb8c141b1056a6d964f5b3c9dcd5bd0ba0c1bdb968b634472ec2cf130f
+EBUILD grilo-0.3.9.ebuild 2193 BLAKE2B 26b2d5b383080e9068ffff02008fd4df78a2a960abd8fdc63006cd6e3ab01c2942f9fb1a90fd56b737d25d16fee0081671785cb8d7000be4fda6d2ee61b47e57 SHA512 e948ffb4f03d4009a3a8c3a264ce9eeaeb01b27649e53b675ac35949b8bd2e83903492bf330d7c9c3ac8651c0c61127b4eeb378bfbabebb1b162aa91454dd56e
MISC metadata.xml 728 BLAKE2B f552b3317894c70912c17e3e46367198f4451940b5029508f83ba3ce904faea24ed3876195f1b062145582dd268064e0c63636ddd5d6033b7032b392e10abba0 SHA512 bbd75a063a5697c257dd9084961d6519fb71409dcd1375d66ff25218deee87841c822edfa66d440cd5c6bfbad70942f01b30f2b7e1a3cc9727beac23ca717b5f
diff --git a/media-libs/grilo/grilo-0.3.9.ebuild b/media-libs/grilo/grilo-0.3.9.ebuild
new file mode 100644
index 000000000000..f07a46d3c8d4
--- /dev/null
+++ b/media-libs/grilo/grilo-0.3.9.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson python-any-r1 vala xdg
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.3/0" # subslot is libgrilo-0.3 soname suffix
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk gtk-doc +introspection +network +playlist test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+# oauth could be optional if meson is patched - used for flickr oauth in grilo-test-ui tool
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/libxml2:2
+ network? ( >=net-libs/libsoup-2.41.3:2.4[introspection?] )
+ playlist? ( >=dev-libs/totem-pl-parser-3.4.1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+
+ gtk? (
+ net-libs/liboauth
+ >=x11-libs/gtk+-3.14:3 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.10
+ app-text/docbook-xml-dtd:4.3 )
+ ${PYTHON_DEPS}
+ test? ( sys-apps/dbus )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ sed -i -e "s:'GETTEXT_PACKAGE', meson.project_name():'GETTEXT_PACKAGE', 'grilo-${SLOT%/*}':" meson.build || die
+ sed -i -e "s:meson.project_name():'grilo-${SLOT%/*}':" po/meson.build || die
+ sed -i -e "s:'grilo':'grilo-${SLOT%/*}':" doc/grilo/meson.build || die
+
+ # Drop explicit unversioned vapigen check
+ sed -i -e "/vapigen.*=.*find_program/d" meson.build || die
+
+ # Don't build examples; they get embedded in gtk-doc, thus we don't install the sources with USE=examples either
+ sed -i -e "/subdir('examples')/d" meson.build || die
+
+ xdg_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use network enable-grl-net)
+ $(meson_use playlist enable-grl-pls)
+ $(meson_use gtk-doc enable-gtk-doc)
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk enable-test-ui)
+ $(meson_use vala enable-vala)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die
+}