summaryrefslogtreecommitdiff
path: root/media-libs/graphene
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /media-libs/graphene
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest3
-rw-r--r--media-libs/graphene/graphene-1.8.2.ebuild60
-rw-r--r--media-libs/graphene/metadata.xml11
3 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
new file mode 100644
index 000000000000..0bd5eeb32b1b
--- /dev/null
+++ b/media-libs/graphene/Manifest
@@ -0,0 +1,3 @@
+DIST graphene-1.8.2.tar.xz 127436 BLAKE2B a22251db7cf4719c8a6cde49e6feb0a998d1ec7296fee549a4797d72fa575d4266e48fb5a6d9ebd204b93954a6278b4fa88dc56e5f86d7cf8625a5edc685a09b SHA512 8d250dccac345251081419f4ad7079c8035cb6225e10b23d25799386b067288831c23be667d608228ef44a2f6107ac47fc86bb495eda7881b1336598d6c43234
+EBUILD graphene-1.8.2.ebuild 1718 BLAKE2B 49370ceb307b6276db57a423b96e3faa87fd24d05fde0b11369618d9f77686dac8ee68e6d3097f877078610ce4dc88d4b18498484a73b54047ae286d3e3b6fbe SHA512 23fd811f8db072a9fc1cde7ae87702e137f09007dc91b248e8f47d674d716886aa57054d6c5987cbcea1a7b0bc3ea8a85290b9f77b442484c77834ddb1a299c4
+MISC metadata.xml 333 BLAKE2B 3d34baf2b84e2ca8cc20638b381fdb4771e94f07df133f5d997b5d7bdf3704f8b8f77d2c79815f70246affa2e399d1118e03eae7c7cf8e419fec3dae89ef0405 SHA512 aef6b787ac7f14b56e4eacd746c91671b9a115cb40b312b415c7302d4339f5d3b3a887bd52a2b30ba31b3e0f027360a9fa55f6d3065cf7baedc4bd28dbbcd056
diff --git a/media-libs/graphene/graphene-1.8.2.ebuild b/media-libs/graphene/graphene-1.8.2.ebuild
new file mode 100644
index 000000000000..b2b8f26d888b
--- /dev/null
+++ b/media-libs/graphene/graphene-1.8.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit xdg-utils meson multilib-minimal python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ # Disable installed-tests
+ sed -e 's/install: true/install: false/g' -i src/tests/meson.build || die
+}
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ -Dgtk_doc=$(multilib_native_usex doc true false)
+ -Dgobject_types=true
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dbenchmarks=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}
diff --git a/media-libs/graphene/metadata.xml b/media-libs/graphene/metadata.xml
new file mode 100644
index 000000000000..46e32a119ea5
--- /dev/null
+++ b/media-libs/graphene/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ebassi/graphene</remote-id>
+ </upstream>
+</pkgmetadata>