summaryrefslogtreecommitdiff
path: root/media-libs/graphene
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /media-libs/graphene
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest2
-rw-r--r--media-libs/graphene/graphene-1.10.6.ebuild18
2 files changed, 4 insertions, 16 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index 6a96c0f93b12..75631071de0f 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,3 +1,3 @@
DIST graphene-1.10.6.tar.xz 333332 BLAKE2B d353efb22510b78c7360b748b7e83237309b88c170909e521d50e95618e907bd8b2424c3583a5db3ff2ca57954bf793646a69251bbb31caac55155c15981ed3a SHA512 075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72
-EBUILD graphene-1.10.6.ebuild 1716 BLAKE2B f92409d3e8b8af44476171b046e325bfade4e8808b349206dee1cc4374d3604afc0532ba7e0a4830a146ceede305bde2a58607522c96dcb292054cc436fde449 SHA512 b5eac806ceaecb9c13499456fae92be0d4a48ddd8941de973972bb4d32b3711e6ebe2d5ae643531f6f0671433fabe7ede95c4596e3e14292a906da46395425d5
+EBUILD graphene-1.10.6.ebuild 1532 BLAKE2B bc1d794250843f3ac67302da2917f55504535cd17b68009a4d51490aee949b2bddfd031be478877b06509f078e28a89c3ce65b11979979f2b34990ba403715da SHA512 a7bad13274a2301cfed78892acaa7771ff8ec40b6fe0d61db0fba755175317137739f13da240f79bd9368b3b651eca8b4d4973da093c531908126749e94bf9fd
MISC metadata.xml 333 BLAKE2B 3d34baf2b84e2ca8cc20638b381fdb4771e94f07df133f5d997b5d7bdf3704f8b8f77d2c79815f70246affa2e399d1118e03eae7c7cf8e419fec3dae89ef0405 SHA512 aef6b787ac7f14b56e4eacd746c91671b9a115cb40b312b415c7302d4339f5d3b3a887bd52a2b30ba31b3e0f027360a9fa55f6d3065cf7baedc4bd28dbbcd056
diff --git a/media-libs/graphene/graphene-1.10.6.ebuild b/media-libs/graphene/graphene-1.10.6.ebuild
index 50207695d8cd..ab7fb554651e 100644
--- a/media-libs/graphene/graphene-1.10.6.ebuild
+++ b/media-libs/graphene/graphene-1.10.6.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit xdg-utils meson multilib-minimal python-any-r1
+inherit xdg-utils meson-multilib python-any-r1
DESCRIPTION="A thin layer of types for graphic libraries"
HOMEPAGE="https://ebassi.github.io/graphene/"
@@ -34,9 +34,9 @@ BDEPEND="
multilib_src_configure() {
# TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
local emesonargs=(
- -Dgtk_doc=$(multilib_native_usex doc true false)
+ $(meson_native_use_bool doc gtk_doc)
-Dgobject_types=true
- -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ $(meson_native_use_feature introspection)
-Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
$(meson_use cpu_flags_x86_sse2 sse2)
$(meson_use cpu_flags_arm_neon arm_neon)
@@ -45,15 +45,3 @@ multilib_src_configure() {
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}