summaryrefslogtreecommitdiff
path: root/media-libs/graphene
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /media-libs/graphene
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest4
-rw-r--r--media-libs/graphene/graphene-1.10.0.ebuild56
-rw-r--r--media-libs/graphene/graphene-1.8.6.ebuild2
3 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index 363bd3a98a31..52560b837a97 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,3 +1,5 @@
+DIST graphene-1.10.0.tar.xz 289452 BLAKE2B 41af96ffcdb2d8ad2fce7a242cef74cead09ce444514f85a97ac609c6518c60cbd5fb44b58b24973fe9a372f898ca99b79cfd776c968d53b72fc20c5d076a230 SHA512 842ac2c9c2046f07f8421b99292cac348276bb1e025250c7e0dc3ec7f90cb33094b765034862f325dd78f93aa5484ad75a4ad6139fe13330d9e41e3a7cb830d0
DIST graphene-1.8.6.tar.xz 127984 BLAKE2B 7f67b99796cca1a47324674b1871ddfbcce1193ded5f0a37c8c2894d52b6b5823b0fb1909018ea6adb90f7ed53ad6b09eeda9b1606a22a8b85cd0d661d500195 SHA512 ef6e9b5587bd540099216a7e3f7c86eb62368d49876dcd380c9767c6740c8267c9d510c5025dbe56402f3cd15084ef8fc634d3abe486b516f4f5328b87df277c
-EBUILD graphene-1.8.6.ebuild 1838 BLAKE2B 4b22e5dc8b839f4bbd426a6c7c5bcb2efe98ae50ef0fa3e31feda9c0cd6611680d60723bbc9c75e5d0b0c377efdff145a8af57ca82d7ea816a9308e55c03770c SHA512 694d09cabfd35c19a5fdfc1da5efefe44fc78e429ba8da53c4a0610f6338b5f51c483a761e61319ac8dd00559a4a757b1ad30aef576a59ba67b39a1c659d8a55
+EBUILD graphene-1.10.0.ebuild 1697 BLAKE2B 2c8dc2851309627886e0fb939f5b44120ea99e847f563e1dbc034299a38dfa58339cb23d227f5c18c43500d1a0b892d61f626c3abc0e76132daea2f7687ef956 SHA512 189e2deb7cf51ca703aa12138796ac6cabb8a269a4d8564b131ec8289c15d226494f1cba250374c9375ecab3c75a85ef066b404958af7a0f657b464bf39964cc
+EBUILD graphene-1.8.6.ebuild 1839 BLAKE2B eb06a3ebc7e3befed4777fabab55b9a670d5dad677a8cbba50f9afec801e29cc5557dd63a1bde8e4da675d1ececc5c760db8c983ed417c1bfee0fa96872a83ea SHA512 327723ed935545bc2cbbe5590724a2849bbef3e5f72160e4b1f768fbe9c954e39b1d97a7e4a43f81f3b30dff2abf73db66aef3e8b1c1108b0951f7f3a78c98a2
MISC metadata.xml 333 BLAKE2B 3d34baf2b84e2ca8cc20638b381fdb4771e94f07df133f5d997b5d7bdf3704f8b8f77d2c79815f70246affa2e399d1118e03eae7c7cf8e419fec3dae89ef0405 SHA512 aef6b787ac7f14b56e4eacd746c91671b9a115cb40b312b415c7302d4339f5d3b3a887bd52a2b30ba31b3e0f027360a9fa55f6d3065cf7baedc4bd28dbbcd056
diff --git a/media-libs/graphene/graphene-1.10.0.ebuild b/media-libs/graphene/graphene-1.10.0.ebuild
new file mode 100644
index 000000000000..a780160a97cb
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+inherit xdg-utils meson multilib-minimal python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ -Dgtk_doc=$(multilib_native_usex doc true false)
+ -Dgobject_types=true
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}
diff --git a/media-libs/graphene/graphene-1.8.6.ebuild b/media-libs/graphene/graphene-1.8.6.ebuild
index 397385431e0f..e80f1568a132 100644
--- a/media-libs/graphene/graphene-1.8.6.ebuild
+++ b/media-libs/graphene/graphene-1.8.6.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ia64 ppc ppc64 ~sparc x86"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
RESTRICT="!test? ( test )"