summaryrefslogtreecommitdiff
path: root/media-libs/graphene
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /media-libs/graphene
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest1
-rw-r--r--media-libs/graphene/graphene-1.10.2-r1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index eecb3c0eae00..9f6f541a01f0 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,3 +1,4 @@
DIST graphene-1.10.2.tar.xz 292372 BLAKE2B 94553a32dc57216402a9676e11525552c010d970caeb1256dde50ca842b4d673ad78d004d57e7c7a017b8c6e64ad75fc3b03603cba746027ab10befa76d32955 SHA512 a8a8ef1e4ccffee2313a18b9b8dda06c7ede6d49fdde8578694500634e3c90278fd30af7d88938d5ecb08c519cc3e09d21fe69d0f21cb766e056ceedbb3eafb0
+EBUILD graphene-1.10.2-r1.ebuild 1706 BLAKE2B ff096a29e3b6184afdadb0d0a253a1aa35ccac54becd12f49c2c036dcd0aef29b536cbf3d6c6ce70cc8fd59429ed5b2261cefd5faf8d6abfd60b1e969cb21dfc SHA512 e1545d9d6bbcedfdbe59aa222075fd6920b15403a50268d7142f39a5bc33b81d97364cbc268c85f688dad50f79271fc44aa9afb63d92d4b5ff0103ccf07b5ac7
EBUILD graphene-1.10.2.ebuild 1699 BLAKE2B dbfa70bea4f57e2d759cbe4bcbd43d381e485f6fffce1dc412c3d0bd9e51888138afceb49597067bf34aec9f244d941aea64c09c27d693e2367ba5ddd7a5808f SHA512 31368e60b6c0c4b44435e5972352de0748536be54a343b919b0fd4b615cae966ca106b667d9e39c95656866d340226df06cfc2d1e88206099d98059cc7d029f3
MISC metadata.xml 333 BLAKE2B 3d34baf2b84e2ca8cc20638b381fdb4771e94f07df133f5d997b5d7bdf3704f8b8f77d2c79815f70246affa2e399d1118e03eae7c7cf8e419fec3dae89ef0405 SHA512 aef6b787ac7f14b56e4eacd746c91671b9a115cb40b312b415c7302d4339f5d3b3a887bd52a2b30ba31b3e0f027360a9fa55f6d3065cf7baedc4bd28dbbcd056
diff --git a/media-libs/graphene/graphene-1.10.2-r1.ebuild b/media-libs/graphene/graphene-1.10.2-r1.ebuild
new file mode 100644
index 000000000000..0de3c1124ed5
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit xdg-utils meson multilib-minimal python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ -Dgtk_doc=$(multilib_native_usex doc true false)
+ -Dgobject_types=true
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}