summaryrefslogtreecommitdiff
path: root/media-libs/graphene
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /media-libs/graphene
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest2
-rw-r--r--media-libs/graphene/graphene-1.10.8.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index 757b09d46b0e..fb406fb6cfa4 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,4 +1,6 @@
AUX 1.10.6-fix-vector-check.patch 822 BLAKE2B 2a364853cd085fdfc1be38caf792667cc97b0834337abf441bd3fe3dc5e4ffb47496226c8bd93d9935b3725bc3a118b037404317c3d7b70566727e7f48283bd8 SHA512 e4e2d318369b9cc58ac39ece05dbfa919ea614a7d1984ab0ba5128400751843b290dbe921297f86dc54977244378acf76977351e831500d217acf67f1191a825
DIST graphene-1.10.6.tar.xz 333332 BLAKE2B d353efb22510b78c7360b748b7e83237309b88c170909e521d50e95618e907bd8b2424c3583a5db3ff2ca57954bf793646a69251bbb31caac55155c15981ed3a SHA512 075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72
+DIST graphene-1.10.8.tar.gz 178557 BLAKE2B 57739a9cfc246a38968fa8352e0c05ce9e32e50753e7d18b8b25ecebd1ea294cfad26168437e290209011b51085fad7d8a47852b99510a7402f9a7dd00ac17f0 SHA512 526b0c17049459b687ceb7f6c26c9d982535e4048e74a0b6282704f9811d3c2e7e0e6cfef166aa953306b6cf77add6677bc600ae0c66cc052dc04c3d0345bd68
EBUILD graphene-1.10.6-r1.ebuild 1588 BLAKE2B 32190e6be87361dc968579eb5c6ff548595b90dd4e8e93eba90ac5319062c629073435c7259cde7563ffb773a8714670217cbb61a6ab149a86d9cd5095fb9030 SHA512 1de7fdfc0af41108271e1aefa8407f7da31e064b10fc64563f560506ce2b8aef66dabaa99210044405c8d2a97827da532915bf30c8a61385437539c35bb9a27d
+EBUILD graphene-1.10.8.ebuild 1549 BLAKE2B d1d5e4869c9edd215f74919486fc560267671168bd41bc5cce0032ef901dce0e50601754608f278af0d12e5e0ccfc510edb391395383399bbce6244951f53398 SHA512 828a8ceeb4ece4d7868471f787d468233ff0e76a9bca0c40bd707c693ed91011977742e10555d62166edf6e871015313729d356b3e05e7faabb20764561c1a00
MISC metadata.xml 334 BLAKE2B 72027568b7436430c57d6ca3e522368786b9219c7b139eeb3c1e04f398539c2f1e78d63c741546813e4118904777c202dc56be114cd27b7056ef289e14cfd074 SHA512 8300692156435706d82417194a9d8fcc6865560b67d723ea38d0a985f7b910f4f9c65cea31049e30fdf854ab2d4d4983197a006803b2b6fb6d28cc7e40746959
diff --git a/media-libs/graphene/graphene-1.10.8.ebuild b/media-libs/graphene/graphene-1.10.8.ebuild
new file mode 100644
index 000000000000..7e96a061cac6
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit xdg-utils meson-multilib python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ $(meson_native_use_bool doc gtk_doc)
+ -Dgobject_types=true
+ $(meson_native_use_feature introspection)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}