summaryrefslogtreecommitdiff
path: root/media-libs/graphene
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /media-libs/graphene
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/Manifest2
-rw-r--r--media-libs/graphene/files/1.10.6-fix-vector-check.patch24
-rw-r--r--media-libs/graphene/graphene-1.10.6-r1.ebuild49
3 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index fd658c320156..ef93496507a4 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,3 +1,5 @@
+AUX 1.10.6-fix-vector-check.patch 822 BLAKE2B 2a364853cd085fdfc1be38caf792667cc97b0834337abf441bd3fe3dc5e4ffb47496226c8bd93d9935b3725bc3a118b037404317c3d7b70566727e7f48283bd8 SHA512 e4e2d318369b9cc58ac39ece05dbfa919ea614a7d1984ab0ba5128400751843b290dbe921297f86dc54977244378acf76977351e831500d217acf67f1191a825
DIST graphene-1.10.6.tar.xz 333332 BLAKE2B d353efb22510b78c7360b748b7e83237309b88c170909e521d50e95618e907bd8b2424c3583a5db3ff2ca57954bf793646a69251bbb31caac55155c15981ed3a SHA512 075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72
+EBUILD graphene-1.10.6-r1.ebuild 1594 BLAKE2B e9258e19662562b5ce19411aaaaf0fc960851cc30adb48c0f7f945cbea8fbf1b53fa280282685220c28c81e14d736e4b7981386651b196c00d440bd9f0553cc2 SHA512 9a69ee04f4a17db082bc798dd4d77fe325109ccfb7eed214240d26b09041c5dbcd025cd4b7abe9e997987682c7f8036aa8461c227b7147fbd7a478b02c5ee271
EBUILD graphene-1.10.6.ebuild 1532 BLAKE2B bc1d794250843f3ac67302da2917f55504535cd17b68009a4d51490aee949b2bddfd031be478877b06509f078e28a89c3ce65b11979979f2b34990ba403715da SHA512 a7bad13274a2301cfed78892acaa7771ff8ec40b6fe0d61db0fba755175317137739f13da240f79bd9368b3b651eca8b4d4973da093c531908126749e94bf9fd
MISC metadata.xml 334 BLAKE2B 72027568b7436430c57d6ca3e522368786b9219c7b139eeb3c1e04f398539c2f1e78d63c741546813e4118904777c202dc56be114cd27b7056ef289e14cfd074 SHA512 8300692156435706d82417194a9d8fcc6865560b67d723ea38d0a985f7b910f4f9c65cea31049e30fdf854ab2d4d4983197a006803b2b6fb6d28cc7e40746959
diff --git a/media-libs/graphene/files/1.10.6-fix-vector-check.patch b/media-libs/graphene/files/1.10.6-fix-vector-check.patch
new file mode 100644
index 000000000000..71d1e28c16a9
--- /dev/null
+++ b/media-libs/graphene/files/1.10.6-fix-vector-check.patch
@@ -0,0 +1,24 @@
+From 3ce7bf419e366d88a141d1210ae96182986ea8e9 Mon Sep 17 00:00:00 2001
+From: q66 <daniel@octaforge.org>
+Date: Wed, 9 Jun 2021 15:47:14 +0200
+Subject: [PATCH] meson: fix gcc vector 64-bit check
+
+the previous behavior only ever enabled gcc vectors no x86_64
+patch origin: https://github.com/ebassi/graphene/pull/233
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 5dbfb63..fd37036 100644
+--- a/meson.build
++++ b/meson.build
+@@ -328,7 +328,7 @@ if get_option('gcc_vector')
+ # error "GCC vector intrinsics are disabled on GCC prior to 4.9"
+ # elif defined(__arm__)
+ # error "GCC vector intrinsics are disabled on ARM"
+-# elif !defined(__x86_64__)
++# elif (__SIZEOF_POINTER__ < 8)
+ # error "GCC vector intrinsics are disabled on 32bit"
+ # endif
+ #else
diff --git a/media-libs/graphene/graphene-1.10.6-r1.ebuild b/media-libs/graphene/graphene-1.10.6-r1.ebuild
new file mode 100644
index 000000000000..29dbe5384376
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit xdg-utils meson-multilib python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${PV}-fix-vector-check.patch" )
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ $(meson_native_use_bool doc gtk_doc)
+ -Dgobject_types=true
+ $(meson_native_use_feature introspection)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}