summaryrefslogtreecommitdiff
path: root/media-libs/gmmlib/gmmlib-22.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 03:54:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 03:54:54 +0100
commitde9b2d9850ea1cb41c216274646d749ccec8c311 (patch)
treedf9e5db7e51d2a53e8ead0c8c3f01af0bf56df6d /media-libs/gmmlib/gmmlib-22.3.5.ebuild
parent911d13b08c9edf41dd5fd5f5e15c952ca1fc3b6c (diff)
gentoo auto-resync : 30:03:2023 - 03:54:54
Diffstat (limited to 'media-libs/gmmlib/gmmlib-22.3.5.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-22.3.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.3.5.ebuild b/media-libs/gmmlib/gmmlib-22.3.5.ebuild
new file mode 100644
index 000000000000..21abbf34e428
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+
+inherit cmake-multilib
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}