summaryrefslogtreecommitdiff
path: root/media-libs/gmmlib/gmmlib-22.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /media-libs/gmmlib/gmmlib-22.0.2.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'media-libs/gmmlib/gmmlib-22.0.2.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-22.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.0.2.ebuild b/media-libs/gmmlib/gmmlib-22.0.2.ebuild
new file mode 100644
index 000000000000..1e2a71912bdd
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.4.1_custom_cflags.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}