summaryrefslogtreecommitdiff
path: root/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch')
-rw-r--r--media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch b/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch
new file mode 100644
index 000000000000..7d826fabd0a7
--- /dev/null
+++ b/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch
@@ -0,0 +1,42 @@
+Makes the test suite run in src_test(), not src_compile(). Note that
+at the moment all the output from the test runner goes into the CTest log
+and all that src_test() shows is the overall status of the execution
+of the runner.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,8 +1,6 @@
+ cmake_minimum_required (VERSION 3.1 FATAL_ERROR)
+
+-if (NOT DEFINED RUN_TEST_SUITE)
+-option (RUN_TEST_SUITE "run test suite after install" ON)
+-endif (NOT DEFINED RUN_TEST_SUITE)
++include(CTest)
+
+ add_subdirectory(Source/GmmLib)
+
+--- a/Source/GmmLib/CMakeLists.txt
++++ b/Source/GmmLib/CMakeLists.txt
+@@ -495,7 +495,7 @@
+ _X64)
+ endif()
+
+-if(NOT DEFINED RUN_TEST_SUITE OR RUN_TEST_SUITE)
++if(BUILD_TESTING)
+ add_subdirectory(ULT)
+ endif()
+
+--- a/Source/GmmLib/ULT/CMakeLists.txt
++++ b/Source/GmmLib/ULT/CMakeLists.txt
+@@ -151,9 +151,7 @@
+
+ add_custom_target(Run_ULT ALL DEPENDS GMMULT)
+
+-add_custom_command(
+- TARGET Run_ULT
+- POST_BUILD
+- COMMAND echo running ULTs
++add_test(
++ NAME Run_ULT
+ COMMAND "${CMAKE_COMMAND}" -E env "LD_LIBRARY_PATH=$<TARGET_FILE_DIR:igfx_gmmumd_dll>" ${CMAKE_CFG_INTDIR}/${EXE_NAME} --gtest_filter=CTest*
+ )