summaryrefslogtreecommitdiff
path: root/media-libs/glyr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/glyr
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/glyr')
-rw-r--r--media-libs/glyr/Manifest3
-rw-r--r--media-libs/glyr/files/glyr-1.0.10-fix-version.patch23
-rw-r--r--media-libs/glyr/glyr-1.0.10-r1.ebuild (renamed from media-libs/glyr/glyr-1.0.10.ebuild)24
3 files changed, 37 insertions, 13 deletions
diff --git a/media-libs/glyr/Manifest b/media-libs/glyr/Manifest
index cb1ea84959fb..16cc62fd5503 100644
--- a/media-libs/glyr/Manifest
+++ b/media-libs/glyr/Manifest
@@ -1,3 +1,4 @@
+AUX glyr-1.0.10-fix-version.patch 739 BLAKE2B a39fb9efa6d5f94c7de099036267f059f6b5ae1b4272c40af0c270e58b81d3331821739b8cdb370fa1d94577c47ecf5684c43900f809a3c7fa830352a9ba2b4e SHA512 84512d32476724e19effef9c01306cf77b62a3044c00213a7ee5d34710f20eda88f65ace38592e0391a5f1c15c2d5e2cbae8b28ac660ded6abead2a5508bc76d
DIST glyr-1.0.10.tar.gz 416414 BLAKE2B 6cc4dbe7f95bb86635c131f37e4a0d0c95cf2027e8d84629e5d2760d9d8baa5194976b119f2759922ad6a3a2986cc22c630260bb85108caf04674d12a43b1406 SHA512 dc5a579c84c321de7c28861e42196d42ef73bbdbe86b5d662d7ace1d79efe8d6d8d0a8086092ed9c32af9651db8cb11bf1678c5582b17192b23e20a66812bb21
-EBUILD glyr-1.0.10.ebuild 748 BLAKE2B 41feff88821280b8c2564c42646cd80e1a7791db1107d00d0dd8bf504ae1de1409042de109f94d84997e630f32979e1875c10a9f1c823b53804e888a19cadb0a SHA512 bf35304a65a57739aa46af25d5042cddc75790d18b34569c5e86d1007b692191983aa9a46e927b3630c05e220d9a0fe9b79c0ae8cbe1586970c059033c5b7efb
+EBUILD glyr-1.0.10-r1.ebuild 784 BLAKE2B 357e6e6b8ee6ee834ac5c758815e3529e4e387297dbfed6b02a56b9f0df4aa0d5041c33187e8f0b1f3b8c258fa2104ce0bfa9616bcee22b5a30112a8ee3af04d SHA512 3aa6af29794ee0c569a21a2a7b9647896a92ab434b03892a45cdbd6204322d59bafab0969f2737694a72f71e9ec03da34e0ffe54831fd72e55d1a10ed4dec99d
MISC metadata.xml 329 BLAKE2B 8f3f81df3e002776e233ae65958ca1efc0ab83663f440030b957e14bb932b42d63f2f2fc90c0c2bebc463bb36fd469e1271c2eebd3074d21d3e852666a8a272f SHA512 3cb53de8df8679ce2cd675c4308b70f5b0f359a267284c225126c909d38a127d1dbe5fdc3f2450ce98054cd63c150afefce6e94adb174500a158e8a0d38cf5e4
diff --git a/media-libs/glyr/files/glyr-1.0.10-fix-version.patch b/media-libs/glyr/files/glyr-1.0.10-fix-version.patch
new file mode 100644
index 000000000000..0d0c126faa7f
--- /dev/null
+++ b/media-libs/glyr/files/glyr-1.0.10-fix-version.patch
@@ -0,0 +1,23 @@
+https://github.com/sahib/glyr/pull/104
+
+From bf0a0f0a040aed89f7fef3dadf52754b73efc597 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 27 Feb 2022 00:48:25 +0000
+Subject: [PATCH] CMakeLists.txt: fix version
+
+This avoids e.g. the pkg-config file installed having the wrong version.
+
+It must be updated on new tags/releases (just before tagging).
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,7 +38,7 @@ ENDIF()
+ # ------------------------------------------------
+ SET(GLYR_VERSION_MAJOR "1")
+ SET(GLYR_VERSION_MINOR "0")
+-SET(GLYR_VERSION_MICRO "9")
++SET(GLYR_VERSION_MICRO "10")
+ SET(GLYR_VERSION_NAME "Raving Raven")
+ # ------------------------------------------------
+
diff --git a/media-libs/glyr/glyr-1.0.10.ebuild b/media-libs/glyr/glyr-1.0.10-r1.ebuild
index 65ac5aac4cf9..b4710e885734 100644
--- a/media-libs/glyr/glyr-1.0.10.ebuild
+++ b/media-libs/glyr/glyr-1.0.10-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Music related metadata searchengine, both with commandline interface and C API"
HOMEPAGE="https://github.com/sahib/glyr"
@@ -12,21 +12,21 @@ SRC_URI="https://github.com/sahib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="
- dev-db/sqlite:3
+RDEPEND="dev-db/sqlite:3
>=dev-libs/glib-2.10:2
- net-misc/curl
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( AUTHORS README.textile ) # CHANGELOG is obsolete in favour of git history
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-version.patch
+)
+
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i \
-e '/GCC_ONLY_OPT.*-s/d' \