summaryrefslogtreecommitdiff
path: root/media-libs/glu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /media-libs/glu
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'media-libs/glu')
-rw-r--r--media-libs/glu/Manifest4
-rw-r--r--media-libs/glu/glu-9.0.1.ebuild48
-rw-r--r--media-libs/glu/glu-9999.ebuild8
3 files changed, 54 insertions, 6 deletions
diff --git a/media-libs/glu/Manifest b/media-libs/glu/Manifest
index f92ab0e2c97d..fe55c0267a59 100644
--- a/media-libs/glu/Manifest
+++ b/media-libs/glu/Manifest
@@ -1,4 +1,6 @@
DIST glu-9.0.0.tar.bz2 493206 BLAKE2B 9c8c27bf8b415f4962079f200f64d4ecadaabecc7cddf832ccc75146b30260bb386ddb87cee26d911f6b7c2451ed0484e0fe8bfa39ac27e33b87a2b5d025ca81 SHA512 ff920e3fbca739794e1432a92fdd8517aa732110fea71ed724185425042f83ce18e9866c16f95c6e10f6993f0814a90fac9636e2b3d8ca2084d1ac0a860f61c8
+DIST glu-9.0.1.tar.xz 434632 BLAKE2B ed624b107a97ac84517cd0fa740090746ab93c77498135bf6dae3ee488e04afc93b0d239aba15533de8ab407d3d3d5e7cb5086b29985d93037e78753b249741e SHA512 8a6dae5b4bd63efb96d15f23ccda4ad9c2ffaa964897e5fa63d1e58360d8d4e6732c5efd2109dba04155d5fc457ab1718a65cf9b544ce0d452679ba988d04018
EBUILD glu-9.0.0-r1.ebuild 861 BLAKE2B 805c6ecf0287e0f91fd21ef79463ec98fe4fd129cb9dc5fe18783a0e31c3e4ad7990963c719a8dc19cdf589a3797a88af20ff0042a5901a1b0d3323956d04307 SHA512 b4afff965bb31272039f8ebbf3bc0b852eca73feadb275160bf9fb4ec01dd39970dc2e1e3d551e87df00083f1663e96faa388c8e92cb84cda259698d596d48db
-EBUILD glu-9999.ebuild 1110 BLAKE2B ff62ebb8660e3507d3bb8a72859a52b914577e25bbdcb1cee3a665988b3eb9c37d44e4f1036dbfc34ce564e7efbaa5a51112894b8afa66cef008949a9fbdfe89 SHA512 f60e1a9f41a41488e8d53d1c1fd11d07e44d5a29e00b87af9d640d01ea3b711a5b36bac1fca2aa22ab4257e2be6275e5f18fa4a07e83f40636236d3172bc1cdc
+EBUILD glu-9.0.1.ebuild 1057 BLAKE2B b643ab76123ed0a288e27d70a867b78e52b9c86ffdf98887018aed7408093fef81c5b2072658853fcad39fc44f8bb6d44f3d433edb7e34d8f015816c1c48bdcc SHA512 33a465a89ddf272688c17e1418190c94e4867c1ba77d9340dc4c49ec9c40fa6dd6bcfe88c2d4e680d1aec84ad75ac1311a2c9910179cb9ed88009ae574a1d8ad
+EBUILD glu-9999.ebuild 1057 BLAKE2B b643ab76123ed0a288e27d70a867b78e52b9c86ffdf98887018aed7408093fef81c5b2072658853fcad39fc44f8bb6d44f3d433edb7e34d8f015816c1c48bdcc SHA512 33a465a89ddf272688c17e1418190c94e4867c1ba77d9340dc4c49ec9c40fa6dd6bcfe88c2d4e680d1aec84ad75ac1311a2c9910179cb9ed88009ae574a1d8ad
MISC metadata.xml 240 BLAKE2B 7361e68ba9e9d62530d9e45896fa3473e5606d67f87f78f4be394145abb8ee5851fff417cbd973c913a05ce60530eca628c3864cfeef75bf7b5f69b3e8e87da8 SHA512 e23d56b08b47406b57f50a1028febb4c4e1809ce967715b2a46aed1124dfaf306a85a3b2398c4ce058df4305bfc8645b79e8ef3569e6cfe8ec467f63e967b5d1
diff --git a/media-libs/glu/glu-9.0.1.ebuild b/media-libs/glu/glu-9.0.1.ebuild
new file mode 100644
index 000000000000..ec7ab407c722
--- /dev/null
+++ b/media-libs/glu/glu-9.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit autotools multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}
+ !<media-libs/mesa-9"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+src_test() {
+ :;
+}
diff --git a/media-libs/glu/glu-9999.ebuild b/media-libs/glu/glu-9999.ebuild
index b743ef44af75..ec7ab407c722 100644
--- a/media-libs/glu/glu-9999.ebuild
+++ b/media-libs/glu/glu-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,9 +6,7 @@ EAPI=7
EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
if [[ ${PV} = 9999* ]]; then
- AUTOTOOLS_AUTORECONF=1
GIT_ECLASS="git-r3"
- EXPERIMENTAL="true"
fi
inherit autotools multilib-minimal ${GIT_ECLASS}
@@ -19,7 +17,7 @@ HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
- SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.bz2"
+ SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
@@ -32,7 +30,7 @@ RDEPEND="${DEPEND}
!<media-libs/mesa-9"
src_prepare() {
- eapply_user
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}