summaryrefslogtreecommitdiff
path: root/media-libs/glm/glm-0.9.9.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /media-libs/glm/glm-0.9.9.8-r1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'media-libs/glm/glm-0.9.9.8-r1.ebuild')
-rw-r--r--media-libs/glm/glm-0.9.9.8-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-libs/glm/glm-0.9.9.8-r1.ebuild b/media-libs/glm/glm-0.9.9.8-r1.ebuild
index 04922fcc2113..1b411e2a5fab 100644
--- a/media-libs/glm/glm-0.9.9.8-r1.ebuild
+++ b/media-libs/glm/glm-0.9.9.8-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="OpenGL Mathematics"
HOMEPAGE="http://glm.g-truc.net/"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="|| ( HappyBunny MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ppc64 ~riscv sparc x86"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
RESTRICT="!test? ( test )"
@@ -24,6 +24,10 @@ PATCHES=(
src_configure() {
# Header-only library
if use test; then
+ # See https://github.com/g-truc/glm/pull/1087
+ # https://bugs.gentoo.org/818235
+ append-cxxflags -fno-ipa-modref
+
local mycmakeargs=(
-DGLM_TEST_ENABLE=ON
-DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"