summaryrefslogtreecommitdiff
path: root/media-libs/glfw/glfw-3.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
commit590b9b7b03bf4651e099949e318755af7cfa81b8 (patch)
tree54c184b7d26c25f1922bfeaf19a1dd45a2e3b1eb /media-libs/glfw/glfw-3.3.4.ebuild
parentf4fc10428424904caf2035cffc442195cb088b2c (diff)
gentoo resync : 01.08.2021
Diffstat (limited to 'media-libs/glfw/glfw-3.3.4.ebuild')
-rw-r--r--media-libs/glfw/glfw-3.3.4.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/media-libs/glfw/glfw-3.3.4.ebuild b/media-libs/glfw/glfw-3.3.4.ebuild
deleted file mode 100644
index 126bde0fc027..000000000000
--- a/media-libs/glfw/glfw-3.3.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="The Portable OpenGL FrameWork"
-HOMEPAGE="https://www.glfw.org/"
-SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc64 x86"
-IUSE="wayland"
-
-RDEPEND="
- x11-libs/libxkbcommon
- !wayland? (
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXcursor
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXxf86vm
- )
- wayland? (
- dev-libs/wayland
- media-libs/mesa[egl,wayland]
- )
-"
-DEPEND="
- ${RDEPEND}
- !wayland? ( x11-libs/libXi )
- wayland? ( dev-libs/wayland-protocols )
-"
-BDEPEND="
- wayland? ( kde-frameworks/extra-cmake-modules )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DGLFW_BUILD_EXAMPLES=no
- -DGLFW_USE_WAYLAND="$(usex wayland)"
- -DBUILD_SHARED_LIBS=1
- )
- cmake_src_configure
-}