summaryrefslogtreecommitdiff
path: root/media-libs/glfw/glfw-3.3.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /media-libs/glfw/glfw-3.3.4-r3.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'media-libs/glfw/glfw-3.3.4-r3.ebuild')
-rw-r--r--media-libs/glfw/glfw-3.3.4-r3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/media-libs/glfw/glfw-3.3.4-r3.ebuild b/media-libs/glfw/glfw-3.3.4-r3.ebuild
deleted file mode 100644
index 73e3566ec70b..000000000000
--- a/media-libs/glfw/glfw-3.3.4-r3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="Portable OpenGL FrameWork"
-HOMEPAGE="https://www.glfw.org/"
-SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc64 x86"
-IUSE="wayland-only"
-
-# note: libglfw uses dlopen() for most of these at runtime
-RDEPEND="
- x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
- wayland-only? (
- dev-libs/wayland[${MULTILIB_USEDEP}]
- media-libs/mesa[egl(+),wayland,${MULTILIB_USEDEP}]
- )
- !wayland-only? (
- virtual/opengl[${MULTILIB_USEDEP}]
- x11-libs/libX11[${MULTILIB_USEDEP}]
- x11-libs/libXcursor[${MULTILIB_USEDEP}]
- x11-libs/libXinerama[${MULTILIB_USEDEP}]
- x11-libs/libXrandr[${MULTILIB_USEDEP}]
- x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
- )"
-DEPEND="
- ${RDEPEND}
- wayland-only? ( dev-libs/wayland-protocols )
- !wayland-only? (
- x11-base/xorg-proto
- x11-libs/libXi[${MULTILIB_USEDEP}]
- )"
-BDEPEND="
- wayland-only? (
- dev-util/wayland-scanner
- kde-frameworks/extra-cmake-modules
- )"
-
-src_configure() {
- local mycmakeargs=(
- -DGLFW_BUILD_EXAMPLES=no
- -DGLFW_USE_WAYLAND=$(usex wayland-only)
- )
- cmake-multilib_src_configure
-}