summaryrefslogtreecommitdiff
path: root/media-libs/glfw/glfw-3.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-libs/glfw/glfw-3.3.3.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-libs/glfw/glfw-3.3.3.ebuild')
-rw-r--r--media-libs/glfw/glfw-3.3.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/glfw/glfw-3.3.3.ebuild b/media-libs/glfw/glfw-3.3.3.ebuild
new file mode 100644
index 000000000000..ea8df33cd67c
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+IUSE="wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon
+ !wayland? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ wayland? (
+ dev-libs/wayland
+ media-libs/mesa[egl,wayland]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ !wayland? ( x11-libs/libXi )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? ( kde-frameworks/extra-cmake-modules )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake_src_configure
+}