summaryrefslogtreecommitdiff
path: root/media-libs/gexiv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-30 01:25:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-30 01:25:53 +0100
commitf16e0a3eea2c1d2e5c495ed1802dea365b4fda4b (patch)
tree8942fce466ff12eb53fafa1a5731ff2751fcd593 /media-libs/gexiv2
parent04ac238703da84168e02b06fb131d1d17d85be23 (diff)
gentoo auto-resync : 30:09:2024 - 01:25:52
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/Manifest2
-rw-r--r--media-libs/gexiv2/gexiv2-0.14.3.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index 3d8e0d610618..132d41ddfbf4 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,3 +1,5 @@
DIST gexiv2-0.14.2.tar.xz 389488 BLAKE2B 37e79b1dd4c4324d4d7e2ef709b803a11aff4fbbe50ce5f0a4ff3f0053c77e251150297c1d0b42399c08f67bb669ee88b1e53ea1e853689480b3491ab45bc3e5 SHA512 16536be5180d5f13f549a68f5b701343a1246eca99083e43e6fc700b151614ea80696f931fcbc721b05955173e3206819b593e5b0fcd8ad4fd7d3b287d9c1441
+DIST gexiv2-0.14.3.tar.xz 389976 BLAKE2B 157e551ff74ab8158343b993b5eccfb282f9acc851fb43c60886b199b0cc309958efd0440304b49d69ef6cd8969755fd8a6a31c9733b15d16a21e8f90cdff223 SHA512 24c97fa09b9ee32cb98da4637ea78eb72ae7e2d1792f9ebb31d63e305b3e0e1f6935b8647589c76c39ba631a15c1d8d2f3879c7dff81433786e9533b6348b6a0
EBUILD gexiv2-0.14.2.ebuild 1764 BLAKE2B 1aa5695c234829325986c764472e00596f3a9aacde11b2993d71633e694c45c5f2d569fac08b0f23701c2fe1013d54adc09d29b288a99e082c38c68b0b48ba48 SHA512 43e746d935da379654b50f05ec0157679e5dac8bc62111a87425794427c3b97bf3f2cfa83dd0d0230be80333047e58a2383c06300873ae0fdbd3475bba78e114
+EBUILD gexiv2-0.14.3.ebuild 1770 BLAKE2B 84acc2767f821da0978042f52c2f92f8ffb99ad236289306e39ee0ef369c39f12af8df4a570d89fa84c6e693bfad37e3222fc3fad8bc8e868fb053fff5c80873 SHA512 df268b20d387737e60e5bd3023a5c87931e84d8c18134e903e032891a96aadf74edc290bb1f0bedefda8a08b367a049e72cb0db485664d2a924b283cbf0c2a6e
MISC metadata.xml 615 BLAKE2B 76b7eab8ca423cb9a816de9ee01bcf7211b14da002292e95bda41db4ed779523b97b95115803ab10ba6b4117c03ff1fd83308d6eac111c1a7813620cc5c56080 SHA512 0a85fe161f01d944a319018dd1dd63b96eafb1d83f3547c707498697dc554088c5ab9fa8fd978a326357fc8a78728e548da2f16b2ccfdcbd2b6c68c5d3623f85
diff --git a/media-libs/gexiv2/gexiv2-0.14.3.ebuild b/media-libs/gexiv2/gexiv2-0.14.3.ebuild
new file mode 100644
index 000000000000..5a52d62a46fb
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.14.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome.org meson python-r1 vala
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+IUSE="gtk-doc +introspection python test +vala"
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=media-gfx/exiv2-0.26:=
+ >=dev-libs/glib-2.46.0:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ test? ( media-gfx/exiv2[xmp] )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ -Dtools=false # requires vala, freshly promoted tool that some other distros don't ship yet either
+ # Prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules)
+ -Dpython3=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ python_foreach_impl python_optimize
+ fi
+}