summaryrefslogtreecommitdiff
path: root/media-libs/gexiv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /media-libs/gexiv2
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/Manifest2
-rw-r--r--media-libs/gexiv2/gexiv2-0.13.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index 7aabbf8fb8cd..b8a6c190b372 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,3 +1,5 @@
DIST gexiv2-0.12.2.tar.xz 378428 BLAKE2B bb3fd6310cdb76f3e88bb31e018d78013bb626559b9e95bf59688601388cff10739c20c431fa9539c1d24c9045d2b3590a0f783a994d3b8966c4df12e9127f4e SHA512 850bf41f6180b0fdd050ab08da6e3bbd8d25ffc25a1f48e17a1d7a65771893cc79fba9cbd6718bf1754251ac4a4754983f0ab8f006a05f8c4a15085846d001a5
+DIST gexiv2-0.13.0.tar.xz 387188 BLAKE2B 25550fd0b711e1363da1f6144af482709b52b0334e326a211919fcc97ccaef1832978a31d8d7ec111caf3f3b9b4db3537d818d35199da2e0b6250098c6d99d01 SHA512 dcd94a8e8ab7e3764bf652514222c3cce4537bf2658905405a25d1dd18878e67343060f5b1cf9fd8b11acf4dd2b727a9d49a0d8f379838c60c92de69f0bed2c5
EBUILD gexiv2-0.12.2.ebuild 1792 BLAKE2B d340d1c9249a8d40f1033354fc784f2257076ab156c92da315ee42ba5e1288b7386d53720e3c9a41f8c15ef8919f7207ebab6c69700e87fa2e929a87cb48b7a8 SHA512 06cf3a12ce5f33132433134da2fde272c0151e76189e51b058fcb94942de869ecacbc11571387f5d90c6fdb0c960de8c075f93c88f97b014024104d0d04fd784
+EBUILD gexiv2-0.13.0.ebuild 1812 BLAKE2B 4da38dce9112359317b4f5f732847991a03c51833cac03c7fdf30565bc495fd0285f1cd1134a3aad68967c457c7a97a228e637d3d42f4bf16a8bfd141814d320 SHA512 78a839a2294d065fbb93fd6bec8edf0bab434e1ad20b0cb3919344a5dcd9ed62945b3295db3082a8d2d92092dbeec1f784713f9f21492386d1461bf78bacea9f
MISC metadata.xml 513 BLAKE2B 7820281c36922b5e68aacb3c3935f7193e2725515f196eaf72f6eba42327a8c8d10ceaed6422fb95cf15b0f1a0d96a168c7a677e42ae847fe050b26c39c39a0b SHA512 deb951010c3342738d8ad5b9e79baa790913f3b906799f9f72f59d4e978f0564fc52f14482bb632ffe817488d154bd8bafe98bc5eea07b7c2da1504867d671b0
diff --git a/media-libs/gexiv2/gexiv2-0.13.0.ebuild b/media-libs/gexiv2/gexiv2-0.13.0.ebuild
new file mode 100644
index 000000000000..00f117fc268d
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.13.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson python-r1 vala
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+IUSE="gtk-doc +introspection python static-libs test +vala"
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=media-gfx/exiv2-0.26:=
+ >=dev-libs/glib-2.46.0:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ python? ( ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ test? ( media-gfx/exiv2[xmp] )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ -Dtools=false # requires vala, freshly promoted tool that some other distros don't ship yet either
+ # Prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules)
+ -Dpython3=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ python_foreach_impl python_optimize
+ fi
+}