summaryrefslogtreecommitdiff
path: root/media-libs/gexiv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
commit5c636a121a9064a4373d06b60d49a6f5d67c0e2f (patch)
tree8e5c8c582e12cb579ac94bdaafcd00282252a50d /media-libs/gexiv2
parentb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (diff)
gentoo auto-resync : 25:07:2023 - 05:42:52
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/Manifest2
-rw-r--r--media-libs/gexiv2/gexiv2-0.14.2.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index 0d6b0cb4e9b7..297540e6a14e 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,5 +1,7 @@
AUX 0.14.1-revert-default-cpp_stdto17.patch 623 BLAKE2B b086cdf4a2fd6b5acd197201c6001af3e92cd8b06b80153dbbbd2d6b367f71c15439457774711057443928133096cc5497609f1b09cbdb22e55b6c2757da8bd6 SHA512 a3d37db9925cf157c39ddfb02459e3cf24b6d648929b9409152d7c322ecfdd436461533aa425810e8f5cceadf09baf8426975a832f3158e37e7c82b9d6b74571
DIST gexiv2-0.14.1-Fix-compatibility-with-exiv2-main-branch.patch.xz 7380 BLAKE2B 48cf86c95a0353aa8ceb3c0f5084d9795515ef4534056cf5004d699a93ab50f1e33b27d9df186da2afc2c3ac163228d6b4b1d725ee71675ccc924ceec3e09f20 SHA512 1b4f17841234096e67393cfbabeead8ee09fac037017bbf139cac56edf120ea3af4cbc8659ba13ab380b9aa8b438e79b1097e8ad36872f3252cd4f8d7d52cfe5
DIST gexiv2-0.14.1.tar.xz 387604 BLAKE2B 5939e377d8b20cfa0c000b1fb0311a0a904acb35b5cbb7841e9def80b20b79f42393524e761fa0d20dba5095b55b46a712759569eb869b832190f7448896de82 SHA512 f510e49c0b2633bcc370ca21af0822032f04f5d5b57c7f76807797601b0a98b7749fdf68df37a405c9d90734adf75282a3dad59c24830874f64f7bd33152052d
+DIST gexiv2-0.14.2.tar.xz 389488 BLAKE2B 37e79b1dd4c4324d4d7e2ef709b803a11aff4fbbe50ce5f0a4ff3f0053c77e251150297c1d0b42399c08f67bb669ee88b1e53ea1e853689480b3491ab45bc3e5 SHA512 16536be5180d5f13f549a68f5b701343a1246eca99083e43e6fc700b151614ea80696f931fcbc721b05955173e3206819b593e5b0fcd8ad4fd7d3b287d9c1441
EBUILD gexiv2-0.14.1-r1.ebuild 2013 BLAKE2B fd806e3c2e101dd5f42145ae911efb7df49d8e40ba2a76338e69ba540fd57f6c053b6d88c7b06722c34431e03defa5394e1be46e1e17f63218eba59d40b8c0cf SHA512 bbb9225c2855f71f14fc226dc55f2a352897838b052d15142336969ab25e432da4b2a9ac786291fc3fa6dcfa22f003f8a3725a31508dba3bb6f9203a25fb9db5
+EBUILD gexiv2-0.14.2.ebuild 1777 BLAKE2B b84d427669b32cdef5fdb664509e78da99904db275e81b249144c3a5136abbaf1829639646eb7d31ee78310fdea30146babb6b87d287ad2ed3ad92fab1fef8cc SHA512 9cb805b7f88e8608cb6be3a4eeec29ad15c37b010270b13d19f931175253710b6a00f14d4d73094ffba6ed857e7d01dbdc2b2b87bea665476fa62a79cdfe1c56
MISC metadata.xml 615 BLAKE2B 76b7eab8ca423cb9a816de9ee01bcf7211b14da002292e95bda41db4ed779523b97b95115803ab10ba6b4117c03ff1fd83308d6eac111c1a7813620cc5c56080 SHA512 0a85fe161f01d944a319018dd1dd63b96eafb1d83f3547c707498697dc554088c5ab9fa8fd978a326357fc8a78728e548da2f16b2ccfdcbd2b6c68c5d3623f85
diff --git a/media-libs/gexiv2/gexiv2-0.14.2.ebuild b/media-libs/gexiv2/gexiv2-0.14.2.ebuild
new file mode 100644
index 000000000000..1c1402775504
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.14.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-r1 vala
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+IUSE="gtk-doc +introspection python test +vala"
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=media-gfx/exiv2-0.26:=
+ >=dev-libs/glib-2.46.0:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ test? ( media-gfx/exiv2[xmp] )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ -Dtools=false # requires vala, freshly promoted tool that some other distros don't ship yet either
+ # Prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules)
+ -Dpython3=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ python_foreach_impl python_optimize
+ fi
+}