summaryrefslogtreecommitdiff
path: root/media-libs/gexiv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-libs/gexiv2
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/Manifest2
-rw-r--r--media-libs/gexiv2/gexiv2-0.12.2.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index f59ece4a2b10..1309d3a29541 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,3 +1,5 @@
DIST gexiv2-0.12.1.tar.xz 372104 BLAKE2B e712bc8056e0e02d66ee831425776c26b65275db8f4cb4a526dbe9f00bddc473312f6c4c8e011906ca02ff256c00c7fe8d602acd64c787b05e13ad582ff8ebee SHA512 cbf83ea79eead9aab15ba760217fd6a1b55a5c60059f14f243327ad7d3c09d6a0528dbdb33a8ee235c76dac5aab0afa8b7d2ab4367fe9128a096dce5da19a68d
+DIST gexiv2-0.12.2.tar.xz 378428 BLAKE2B bb3fd6310cdb76f3e88bb31e018d78013bb626559b9e95bf59688601388cff10739c20c431fa9539c1d24c9045d2b3590a0f783a994d3b8966c4df12e9127f4e SHA512 850bf41f6180b0fdd050ab08da6e3bbd8d25ffc25a1f48e17a1d7a65771893cc79fba9cbd6718bf1754251ac4a4754983f0ab8f006a05f8c4a15085846d001a5
EBUILD gexiv2-0.12.1.ebuild 1785 BLAKE2B f9ee602000fffb2fb5a7da96a8387abe8c5fd20349886197a88b254e43364c45ea0f66c295cb65ce77358338fd805959681bb4c175b837b1deb95427ebcee9fe SHA512 9ca34e4290ad103f6cea1769cf24dfd8df0c74c92a7d50e27e7703d02c09b990a405577cb1237b451ddb4c82761fe6e1a1e2c90719cbf3d369d9dcb35a66de49
+EBUILD gexiv2-0.12.2.ebuild 1792 BLAKE2B a540a47d039ee90ade227d35ce223de1845d13bab3de1252297d62deae99cd246ed6af9b0fc7b2e87e065d19a73725a26de9f1e1153b0f3031fd287d1283e7cb SHA512 c55a23c4286b4bd7d56bb3a99cd2be756bc7d70251cd967c868e636bfecf5f9d71e575cf915d449444556dc9796a3c64ea7f00a9d829f437c64abbad6e63faa4
MISC metadata.xml 513 BLAKE2B 7820281c36922b5e68aacb3c3935f7193e2725515f196eaf72f6eba42327a8c8d10ceaed6422fb95cf15b0f1a0d96a168c7a677e42ae847fe050b26c39c39a0b SHA512 deb951010c3342738d8ad5b9e79baa790913f3b906799f9f72f59d4e978f0564fc52f14482bb632ffe817488d154bd8bafe98bc5eea07b7c2da1504867d671b0
diff --git a/media-libs/gexiv2/gexiv2-0.12.2.ebuild b/media-libs/gexiv2/gexiv2-0.12.2.ebuild
new file mode 100644
index 000000000000..54ea8224ebf4
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.12.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-r1 vala
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+IUSE="gtk-doc +introspection python static-libs test +vala"
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=media-gfx/exiv2-0.26:=
+ >=dev-libs/glib-2.46.0:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ python? ( ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ test? ( media-gfx/exiv2[xmp] )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ -Dtools=false # requires vala, freshly promoted tool that some other distros don't ship yet either
+ # Prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules)
+ -Dpython2_girdir=no
+ -Dpython3_girdir=no
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+}