summaryrefslogtreecommitdiff
path: root/media-libs/gegl/gegl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-libs/gegl/gegl-9999.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-libs/gegl/gegl-9999.ebuild')
-rw-r--r--media-libs/gegl/gegl-9999.ebuild125
1 files changed, 54 insertions, 71 deletions
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index ec1e63cf3a00..015343c90de2 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -2,20 +2,20 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
# vala and introspection support is broken, bug #468208
VALA_USE_DEPEND=vapigen
-inherit autotools gnome2-utils python-any-r1 vala
+inherit meson gnome2-utils python-any-r1 vala
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gegl.git"
SRC_URI=""
else
- SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A graph based image processing framework"
@@ -24,7 +24,7 @@ HOMEPAGE="http://www.gegl.org/"
LICENSE="|| ( GPL-3+ LGPL-3 )"
SLOT="0.4"
-IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection lcms lensfun libav openexr pdf raw sdl svg test tiff umfpack vala v4l webp zlib"
+IUSE="cairo debug ffmpeg introspection lcms lensfun libav openexr pdf raw sdl svg test tiff umfpack vala v4l webp"
REQUIRED_USE="
svg? ( cairo )
vala? ( introspection )
@@ -35,12 +35,13 @@ REQUIRED_USE="
# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
RDEPEND="
>=dev-libs/glib-2.44:2
- dev-libs/json-glib
- >=media-libs/babl-0.1.62
+ >=dev-libs/json-glib-1.2.6
+ >=media-libs/babl-0.1.72[introspection?]
+ media-libs/libnsgif
>=media-libs/libpng-1.6.0:0=
virtual/jpeg:0=
>=x11-libs/gdk-pixbuf-2.32:2
- x11-libs/pango
+ >=x11-libs/pango-1.38.0
cairo? ( >=x11-libs/cairo-1.12.2 )
ffmpeg? (
libav? ( media-video/libav:0= )
@@ -49,7 +50,7 @@ RDEPEND="
introspection? ( >=dev-libs/gobject-introspection-1.32:= )
lcms? ( >=media-libs/lcms-2.8:2 )
lensfun? ( >=media-libs/lensfun-0.2.5 )
- openexr? ( >=media-libs/openexr-2.2.0:= )
+ openexr? ( >=media-libs/openexr-1.6.1:= )
pdf? ( >=app-text/poppler-0.71.0[cairo] )
raw? ( >=media-libs/libraw-0.15.4:0= )
sdl? ( >=media-libs/libsdl-1.2.0 )
@@ -58,7 +59,7 @@ RDEPEND="
umfpack? ( sci-libs/umfpack )
v4l? ( >=media-libs/libv4l-1.0.1 )
webp? ( >=media-libs/libwebp-0.5.0:= )
- zlib? ( >=sys-libs/zlib-1.2.0 )
+ >=sys-libs/zlib-1.2.0
"
DEPEND="${RDEPEND}
dev-lang/perl
@@ -74,6 +75,13 @@ DEPEND="${RDEPEND}
vala? ( $(vala_depend) )
"
+DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
+ "${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
+)
+
pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
@@ -81,9 +89,6 @@ pkg_setup() {
src_prepare() {
default
- # FIXME: the following should be proper patch sent to upstream
- # fix OSX loadable module filename extension
- sed -i -e 's/\.dylib/.bundle/' configure.ac || die
# don't require Apple's OpenCL on versions of OSX that don't have it
if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
@@ -92,9 +97,7 @@ src_prepare() {
# commit 7c78497b : tests that use gegl.png are broken on non-amd64
sed -e '/clones.xml/d' \
-e '/composite-transform.xml/d' \
- -i tests/compositions/Makefile.am || die
-
- eautoreconf
+ -i tests/compositions/meson.build || die
gnome2_environment_reset
@@ -102,67 +105,47 @@ src_prepare() {
}
src_configure() {
- local myeconfargs=(
+ local emesonargs=(
# disable documentation as the generating is bit automagic
# if anyone wants to work on it just create bug with patch
- --disable-docs
- # never enable altering of CFLAGS via profile option
- --disable-profile
- --disable-silent-rules
- # - Parameter --disable-workshop disables any use of Lua, effectivly
- --disable-workshop
- --program-suffix=-${SLOT}
- --with-gdk-pixbuf
- --with-pango
+ -Ddocs=false
+ # - Parameter -Dworkshop=false disables any use of Lua, effectivly
+ -Dworkshop=false
+ $(meson_use introspection)
+
+ -Dexiv2=disabled
+ -Dgdk-pixbuf=enabled
+ -Dgexiv2=disabled
# - There are two checks for dot, one controllable by --with(out)-graphviz
# which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
- --without-graphviz
+ -Dgraphviz=disabled
+ -Djasper=disabled
+ $(meson_feature lcms)
+ $(meson_feature lensfun)
+ $(meson_feature ffmpeg libav)
+ -Dlibjpeg=enabled
+ -Dlibpng=enabled
+ $(meson_feature raw libraw)
+ $(meson_feature svg librsvg)
# libspiro: not in portage main tree
- --without-libspiro
- --without-lua
- --without-mrg
- $(use_enable cpu_flags_x86_mmx mmx)
- $(use_enable cpu_flags_x86_sse sse)
- $(use_enable debug)
- $(use_enable introspection)
- $(use_with cairo)
- $(use_with cairo pangocairo)
- $(use_with ffmpeg libavformat)
- --without-jasper
- $(use_with lcms)
- $(use_with lensfun)
- $(use_with openexr)
- $(use_with pdf popplerglib)
- $(use_with raw libraw)
- $(use_with sdl)
- $(use_with svg librsvg)
- $(use_with tiff libtiff)
- $(use_with umfpack)
+ -Dlibspiro=disabled
+ $(meson_feature tiff libtiff)
# - v4l support does not work with our media-libs/libv4l-0.8.9,
# upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
- $(use_with v4l libv4l)
- $(use_with v4l libv4l2)
- $(use_with vala)
- $(use_with webp)
- $(use_with zlib)
+ $(meson_feature v4l libv4l)
+ $(meson_feature v4l libv4l2)
+ -Dlua=disabled
+ -Dmrg=disabled
+ $(meson_feature openexr)
+ $(meson_feature cairo)
+ -Dpango=enabled
+ $(meson_feature cairo pangocairo)
+ $(meson_feature introspection pygobject)
+ $(meson_feature sdl sdl1)
+ -Dsdl2=disabled
+ $(meson_feature umfpack)
+ $(meson_feature vala vapigen)
+ $(meson_feature webp)
)
-
- if use test; then
- myeconfargs+=( $(use_with ffmpeg gexiv2) )
- else
- myeconfargs+=( --without-gexiv2 )
- fi
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
-
- [[ ${PV} == *9999* ]] && emake ./ChangeLog # "./" prevents "Circular ChangeLog <- ChangeLog dependency dropped."
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
+ meson_src_configure
}