summaryrefslogtreecommitdiff
path: root/media-libs/gegl/gegl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 13:12:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 13:12:41 +0000
commit959575d1af06bc64016d62d064143faba68a4c43 (patch)
treefbab98e9b035f9f858937e73ff342c2df8e17beb /media-libs/gegl/gegl-9999.ebuild
parent14a74a5f982f25582974c2ee235027a041aec36d (diff)
gentoo auto-resync : 25:11:2022 - 13:12:41
Diffstat (limited to 'media-libs/gegl/gegl-9999.ebuild')
-rw-r--r--media-libs/gegl/gegl-9999.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index 0039c8802478..414f2ad28633 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..11} )
# vala and introspection support is broken, bug #468208
VALA_USE_DEPEND=vapigen
-inherit flag-o-matic meson optfeature python-any-r1 vala
+inherit flag-o-matic meson optfeature python-any-r1 toolchain-funcs vala
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -24,7 +24,7 @@ HOMEPAGE="https://gegl.org/"
LICENSE="|| ( GPL-3+ LGPL-3 )"
SLOT="0.4"
-IUSE="cairo debug ffmpeg introspection lcms lensfun openexr pdf raw sdl sdl2 svg test tiff umfpack vala v4l webp"
+IUSE="cairo debug ffmpeg introspection lcms lensfun openexr openmp pdf raw sdl sdl2 svg test tiff umfpack vala v4l webp"
REQUIRED_USE="
svg? ( cairo )
test? ( introspection )
@@ -39,7 +39,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/glib-2.68.2:2
>=dev-libs/json-glib-1.2.6
- >=media-libs/babl-0.1.96[introspection?,lcms?,vala?]
+ >=media-libs/babl-0.1.98[introspection?,lcms?,vala?]
media-libs/libjpeg-turbo
media-libs/libnsgif
>=media-libs/libpng-1.6.0:0=
@@ -76,9 +76,18 @@ BDEPEND="
DOCS=( AUTHORS docs/ChangeLog docs/NEWS.adoc )
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ python-any-r1_pkg_setup
+}
+
python_check_deps() {
use test || return 0
- has_version -b ">=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]"
+ python_has_version -b ">=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]"
}
src_prepare() {
@@ -123,6 +132,7 @@ src_configure() {
$(meson_feature lcms)
$(meson_feature lensfun)
$(meson_feature openexr)
+ $(meson_feature openmp)
$(meson_feature pdf poppler)
$(meson_feature raw libraw)
$(meson_feature sdl sdl1)