summaryrefslogtreecommitdiff
path: root/media-libs/gegl/gegl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-libs/gegl/gegl-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-libs/gegl/gegl-9999.ebuild')
-rw-r--r--media-libs/gegl/gegl-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index c0ed1b98aeaa..72e12f1f01b1 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
VALA_USE_DEPEND=vapigen
-inherit meson gnome2-utils python-any-r1 vala
+inherit meson optfeature python-any-r1 vala
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -72,7 +72,7 @@ BDEPEND="
vala? ( $(vala_depend) )
"
-DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
+DOCS=( AUTHORS docs/ChangeLog docs/NEWS.adoc )
python_check_deps() {
use test || return 0
@@ -99,8 +99,6 @@ src_prepare() {
-e '/composite-transform.xml/d' \
-i tests/compositions/meson.build || die
- gnome2_environment_reset
-
use vala && vala_src_prepare
}
@@ -111,9 +109,6 @@ src_configure() {
-Ddocs=false
-Dexiv2=disabled
-Dgdk-pixbuf=enabled
- # - There are two checks for dot, one controllable by --with(out)-graphviz
- # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
- -Dgraphviz=disabled
-Djasper=disabled
# - libspiro: not in portage main tree
-Dlibspiro=disabled
@@ -146,3 +141,7 @@ src_configure() {
)
meson_src_configure
}
+
+pkg_postinst() {
+ optfeature "'Show Image Graph' under GIMP[debug] menu 'File - Debug'" media-gfx/graphviz
+}