summaryrefslogtreecommitdiff
path: root/media-libs/gegl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /media-libs/gegl/files
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'media-libs/gegl/files')
-rw-r--r--media-libs/gegl/files/gegl-0.2.0-ffmpeg-av_frame_alloc.patch38
-rw-r--r--media-libs/gegl/files/gegl-0.2.0-fix-without-exiv2.patch30
2 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.2.0-ffmpeg-av_frame_alloc.patch b/media-libs/gegl/files/gegl-0.2.0-ffmpeg-av_frame_alloc.patch
new file mode 100644
index 000000000000..6998a02e75f5
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.2.0-ffmpeg-av_frame_alloc.patch
@@ -0,0 +1,38 @@
+From 6e9ac140385d28210afdd2ed2bf9b0533ca0aac1 Mon Sep 17 00:00:00 2001
+From: fafryd <dz1125.bug.tracker@gmail.com>
+Date: Sat, 5 Mar 2016 22:11:39 +0100
+Subject: [PATCH] use av_frame_alloc instead of avcodec_alloc_frame
+
+---
+ operations/external/ff-load.c | 2 +-
+ operations/workshop/external/ff-save.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/operations/external/ff-load.c b/operations/external/ff-load.c
+index 442ec5f..0b9d8e8 100644
+--- a/operations/external/ff-load.c
++++ b/operations/external/ff-load.c
+@@ -321,7 +321,7 @@ prepare (GeglOperation *operation)
+ p->width = p->enc->width;
+ p->height = p->enc->height;
+ p->frames = 10000000;
+- p->lavc_frame = avcodec_alloc_frame ();
++ p->lavc_frame = av_frame_alloc ();
+
+ if (p->fourcc)
+ g_free (p->fourcc);
+diff --git a/operations/workshop/external/ff-save.c b/operations/workshop/external/ff-save.c
+index 0f3105d..84d68c5 100644
+--- a/operations/workshop/external/ff-save.c
++++ b/operations/workshop/external/ff-save.c
+@@ -537,7 +537,7 @@ alloc_picture (int pix_fmt, int width, int height)
+ uint8_t *picture_buf;
+ int size;
+
+- picture = avcodec_alloc_frame ();
++ picture = av_frame_alloc ();
+ if (!picture)
+ return NULL;
+ size = avpicture_get_size (pix_fmt, width, height);
+--
+2.7.2
diff --git a/media-libs/gegl/files/gegl-0.2.0-fix-without-exiv2.patch b/media-libs/gegl/files/gegl-0.2.0-fix-without-exiv2.patch
new file mode 100644
index 000000000000..96a4188926df
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.2.0-fix-without-exiv2.patch
@@ -0,0 +1,30 @@
+From c0b4da18e199d1043738c034269f5dd6a4aa7d99 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Wed, 10 Jan 2018 22:39:05 +0100
+Subject: [PATCH] Fix ./configure --without-exiv2
+
+Variable names were in error
+
+Bug: https://bugs.gentoo.org/641872
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 30d306e..146b271 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -977,8 +977,8 @@ AC_SUBST(LIBSPIRO)
+
+ AC_ARG_WITH(exiv2, [ --without-exiv2 build without libexiv2 support])
+
+-have_libexiv2="no"
+-if test "x$with_libexiv2" != "xno"; then
++have_exiv2="no"
++if test "x$with_exiv2" != "xno"; then
+ PKG_CHECK_MODULES(EXIV2, exiv2,
+ have_exiv2="yes",
+ have_exiv2="no (exiv2 library not found)")
+--
+2.16.0.rc0
+